Buffering during playback - Google Drive

Recently I have come to a problem with my Apple TV 4K when using the app, there was no issue last month. Now, the videos I play from google drive keep buffering every minute or 5 minutes apart from each buffering. I did uninstalled the app, rebuild the metadata, restarted the playback and look up for solutions for my problem. All I came across was for problems that did not apply to my problem. The videos are made for pass-thru playback. Is there anything I can do?

I should had mentioned that the videos are transcoded in 1080p, AAC, so it should not be that hard for the Apple TV 4K to play them.

EDIT: I found the problem, I appear to have a bad connection with Google Drive Servers. This is far from my reach to solve it. How did I find out? I tried to download a file from my own drive and it was interrupted then it failed.

Welcome to the forum!

Can you try updating to the new 5.9.1 version to see if this helps with your issue?

I am also facing the same issue on both IPhoe and Apple TV 4K.

I am using latest version of Infuse on both Iphone and Apple TV4k but still videos playing using Google Drive are buffering after evey few seconds.

I am a new GSuite user and I only have one movie on the Google Drive but still I am getting this issue.

If I play movies from Plex then I never get issue regarding buffering.

Hi, the problem still there after updating the app.

Hi James,

I am using latest version 5.9.1 on both Iphone and Apple TV and facing buffering issue.

I am getting 23-24 Mbps download speed, so just wanted ro check if that is enough for streaming 4K movie from GSuite?

I never had any problems on 45gb below playback via Google suite, but now I can’t even get past 4 seconds upon playback on a 1080p video. This just happened recently via the Infuse tvOs app. Playback and download via browser seems to be working well. I have 50mbps download and the same problem seems to be happening on each and every single video I’ve tried.

Update: Playback is stuck with the spinning wheel icon and never resumes. I have tried multiple times on different types of videos ranging from 4k, 1080p, 1080p UHD and 720p.

Update 2: I’ve tried switching to LAN and I’m getting to buffering after the 6 second mark instead of 4 via wifi.

Hi NeEko,

Thank you for testing and update.

I have also tested playing two 4k movies (61.5 GB and 65 GB) via the web browser connecting directly to GSuite and there is no issue related to buffering, which means that it is not an issue with internet speed.

The problem occurs only when infuse is connecting to GSuite.

Other than those high bitrate 4K rips over 50gb, i never had any problems with any video via Google Suite up until today. And those 50gb videos usually takes 2-5 minutes before buffering occurs. This time it takes 4-6 seconds for any video to buffer then after a few minutes resumes for it to just buffer once again.

It’s possible that may be fast enough for some 4K content, but without knowing the exact file you are trying to play I can’t say for sure.

For example, 4K Blu-rays can have a max bitrate as high as 128 Mbps, so you’d need a pretty fast connection in order to stream these remotely.

FWIW, the upcoming Infuse 6 release will feature an all-new approach to buffering, which will allow it to have much more robust support for remote streaming.

If this just started within the last day or so, it may be caused by factors outside of Infuse (Internet provider, Google Drive, router firmware, etc…). To help eliminate some variables, you may try restarting your Apple TV and network hardware to see if that helps at all.

I’ve tried restarting everything, from the router, tv, appletv & modem but the problem is still there. Other streaming apps seem to be working nicely with no buffer issues at all. Speedtest via appletv shows 49.1mbps 0.073ms jitter 0 packet loss.

Update: I’ll be testing on other cloud sources like OneDrive, Dropbox & Google Teamdrive soon.

Update 2: I finally got it FIXED! Turns out the smartDNS server I was using had problems so I switched it to another one. However, I’m still getting playback buffering (5-15sec) for those high bitrate 4K videos (Ave bitrate @ 45+mbps) every 2-5 minutes, but it’s probably because of my insufficient internet speed which is currently capped at 50mbps.

So, after a lot of testing, I have increased the download speed to 100 Mbps.

Now, when I get speed above 60 Mbps, then the movie plays smoothly (as all 4k atmos movies that I have aremore than 60 GB in size).
When I get download speed of less than 60Mbps, then I get occasional buffering.

I’ll wait for Infuse version 6.0 which will probably be more suited for Gsuite but right now I think we need more than 60 Mbps download speed for smooth playback of 4k movies.

Great! Glad you got it sorted out.

Things should only get better in Infuse 6. :slight_smile:

More speed is always a good thing. :slight_smile:

We believe the changes coming in Infuse 6 will allow for much improved streaming from Google Drive, and other remote servers…especially with large, high-bitrate files.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.