Buffering Buffering

I’ve had infuse for quite a while and never really had a problem

I am using an Apple TV 4K connected over wifi
I have a USB 4TB HD plugged into my router

With any video file larger than about 15gb, I’m experiencing buffering every couple minutes
The weird thing, is I used the media player built into my LG TV over the same wifi network and can play even the largest 4k file from the network fine, no buffering, no problems

I have the share set to SMB which is what it’s been set too for over a year. I’ve tried using different SMB settings (legacy, SMB1, SMB2, etc.) and cannot get consistent results without buffering throughout

When I create a new share form the same drive using DLNA, it works better but still buffers. The other thing I noticed is that when using MrMC I have the same issue. I’m wondering if something changed on TVOS to cause this, or if I should uninstall and reinstall Infuse (I’d like to not do that and rebuild my library, or if I should reset my ATV back to factory and start over

Any ideas?

1 Like

Is your TV by any chance connected via ethernet to the network?

No. It’s connected via the same WiFi network as the Apple TV

How is the LG TV connecting to your source device? Via SMB, or another method?

It can be hard to compare Wi-Fi performance between different devices, but if you’re seeing the issue with multiple apps on the Apple TV it could be something inherent to the Apple TV/tvOS and your particular network.

If possible, you may try connecting the Apple TV via Ethernet to see if the issue persists.


Same here, 4K stream for NFS and SMB experiencing buffering every 30 sec.
Over DLNA nobuffer, all is smooth but no library :frowning:
I tried over gigabits ethernet cable and the result is the same.
The problem seems to be the SMB protocol.

What SMB level are you using? SMB 3 may be adding to the problem due to some security activity. If it’s set on Auto or 3 try 2.

Also what version of Infuse are you running?

Tryed all, Auto, 1, 2, 3 and Legacy, all same.
For Infuse version it’s the last Induse Pro 6.1.3 (2677)

I think he’s asking what SMB level are you using on your router?

What router model do you have?

My configuration is :
Pine64 with openmediavault with SMB2 connected with gigabet Ethernet to a Livebox 4 Sagemcom, and for finish AppleTV 4k connected over WIFI 5Ghz (ethernet tried and the result are same, speedtest give a 300Mb/s).

Are these 1080p or 4K videos? If using 4K and all you have is wireless N it’s not going to work. You need a strong wireless AC to stream 4K. Try plugging the Apple TV in via Ethernet. If that works then it’s your wireless.

Try FTP instead of Samba. Your openmediavault may be having compatibility issues. FTP tends to work much better with less overhead.

Jarvis, please read my post, I answered at all your question in it. In some words, it’s 4K videos, and I tried with gigabit Ethernet and change, buffering still present.
And to be honest it can’t be network because with DLNA the network bandwidth still the same, but there is no buffer.

Gggplaya, i will give a try to the FTP, thanks for your advice.

If FTP doesn’t work check processor usage on your media server and your router (if Possible). The processors might be your bottle neck. Additionally you can try the ole router reboot. I’ve seen weird things happen with other routers (mac tables getting full and not automatically flushing).

Additionally check here: Rock64 4GB poor USB3 HDD performance

These guys have Pine64 boards and have experienced poor performance on usb3


First thanks for your answers.
My NAS on OpenmediaVault is working fine, i don’t have any poor perfomances with my USB3.
Downloading on the NAS from internet is about 30MB/s; and i said MB not Mb.
When i trying to copy media with my laptop with the wifi 5GHZ, the bandwith is 70MB/s with windows10 SMB.
Reading 4K from maptop with WIFI 5Ghz it’s also smooth.

You can’t compare speeds on your windows PC to Apple products or Android products since SMB(Samba) is a native windows protocol. So of course, it’ll be good. Apple has had problems with their implementation of smb over the years, and so has android. My older android tablet could only do 2MB/s of samba transfer using ES explorer and my high bitrate 1080p movies were buffering. Using FTP protocol got me over 10MB/s on the same tablet, so I only used FTP on that tablet.

Openmediavault may not like apple or androids implementation of Samba. Since you said DLNA works fine, I’m thinking this is the case. You should try FTP.

1 Like

Thank you very much gggplaya.
FTP is working perfectly after i set the max connection to 3 (apparently infuse need to have 3 connections).

Hello, I’m experiencing the same issue. I’ve an Apple TV 4k and a Synology NAS. All connected through ethernet gigabit.
I don’t know what has changed but in the past I could watch any 4k movie without any issues. I’ve this issue since one month.

Quick update. Although I still don’t know why 1 device can stream 4K movies over WiFi no problem but Apple TV with Infuse cannot, I hardwired the connection and now have no problems.