Buffering and start delay for large 4k fixed

I’ve read through every post and thread on this here and on other sites over the last couple days, solving this annoying problem. I’m on the latest everything, top of the line PC, great WiFi, aTV4k, etc. What I was running in to since moving up to 4k rips and remuxes, were buffering for the really high bitrate files and a 20-30 start delay for the smaller ones, even though both bitrates were well within all the limits of the network.

Long story short, it’s the Windows SMB implementation. Yes I tried every possible setting and mode, everywhere, with no effect. All I had to do was setup a basic Plex server and connect to it’s share, rather than the SMB shared folder. Instant fix, instant movie start, zero buffering of anything, smooth scrubbing. All over Google Wi-Fi 3 hops away.

If like me you simply store everything on a PC with huge internal storage, do yourself a favor and just switch from a shared folder to Plex. It makes everything better.

Can you explain this a little more please?

do you use plex? Or do you just use its share?

I do not run a plex app. I use the connect to plex, in infuse. Instead of smb

I have something similar with MAC. I don’t use Plex - I just share my iMac external hard drive. It is funny, because DVD movies play without a hitch, but short “home movies” I made with Apple iMovie (mp4) are constantly stopping with the whirling time out symbol. It takes maybe 20 seconds to start and the movies don’t play through from beginning to end without pausing to buffer. Even short 2 minute movies. It is worse if my desktop is doing something and using CPU time. It isn’t just 4K movies…it is all home movies. Even ones directly from my camera.

I can upload the same videos to You Tube and they play without a hitch on the Apple TV

I also have a top of the line iMac, google WiFi, apple TV4k, and an LG 4K OLED.

I’m trying exporting video from Adobe Lighroom - if it doesn’t work, I’ll try Plex (not sure I understand what you did)

Thats why i asked. I think he has created a flex server with his files, and then added the share to infuse. Not 100% sure tho

Yes, that’s what I said.

Real simple:
Install plex server on your computer.
Use connect to Plex, in infuse.
Done.

I was just going to read up on Plex (I have it installed but was not a fan of the user friendliness). I was thinking of only using Plex for my troubled videos (H.264 home videos).

If you use it this way does infuse just play the video, there isnt any conversion or anything happening?

Guys…I don’t know how to make this simpler. YOU DON’T USE THE PLEX APP. You never see it, or the interface. it simply runs to be a share service. Everything is the same, using infuse.

Glad to hear you fixed the issue with the install of Plex. I understand your description - you’re using the Plex server installation simply to serve up the files to the Infuse client.

I’m wondering if a lightweight FTP server (like Filezilla) could have also solved your problem.

I have no need to complicate it further. Installed, clicked a few settings, never have to see it again.

OK…I tried Plex on a test - just my short home videos

BEFORE: Constant pauses to refresh buffer. Maybe 30 second wait to start. Totally unwatchable. The family drifts off to other rooms.
AFTER: Non stop video in all but one case. Most videos started immediately and there was no stoppage. One video required a 20 second stoppage initially. And one video stopped once and after buffering completed with no interruption. The family stays.

Today I’ll test it again and also add a couple of DVD/Blu Rays to the mix.

Thanks for the tip kaelaria.

PS: I wasn’t thinking of using the PLEX app…I had read somewhere the user interface suffers when using Plex…may be something else Im thinking of. The home movies came out better with a picture to help.

Welcome

By the way, do you have background tasks running like Apple Time Machine ?

No and I said I’m PC

Hallo guys,
I have the same problem with 1:1 copy of my 4K BD: delayed start and 20 seconds buffering stop every 40 seconds of movie. I don’t have any problem watching the same contents with Egreat A5. My configuration: Fritz!Box 7530 router (FTTH 1Gbps/300Mbps), gigabit wired lan from the router to ATV4K. 8TB HD SATAIII in a USB 3.0 cabinet connected to the USB 3.0 router port. Fritz!NAS works in smb and ftp.

Your bottleneck is probably the USB connection to your drive on the router. I had the same problem with large rips when connecting a USB drive to my router. I moved to a dedicated synology NAS and all my problems went away. The processor on the router just wasn’t fast enough to handle the throughput.

Thanks for your answer. That’s what I thought at first glance, but with Egreat A5, which is an Android 5.1 Media Box, streaming is smoother. Just few minutes ago I modified my share settings from SMB auto to SMB3 and things improved but not as good as Egreat. I’d really like to reach the same quality level and use only ATV4K for all my needs without buying another piece of hardware. Does the upnp protocol guarantee smoother streaming compared to smb?

It looks like the Fritzbox only supports SMB1, which is quite a bit slower than SMB2/SMB3.

https://en.avm.de/service/fritzbox/fritzbox-7530/knowledge-base/publication/show/3327_SMB-versions-supported-by-the-FRITZ-Box/

You may try FTP, which could be a bit faster.