Buffered Playback - RESOLVED

I’ve been following these discussions of buffered playback for some time (about a year). I have been unable to resolve the issue with all of the advice.

Apple TV 4 (not 4k)
Wired Gigabit (to media center gigabit switch with gigabit to router)
NAS is Iomega StorCenter™ ix4-200d (Gigabit, SMB 1 only, but also running NFS)
Infuse 5.9.6 Pro
Infuse 6.2.3 (not Pro)

Infuse 5.9.6 Pro - Connected through NFS (SMB used to work, but tried NFS based on recommendations), Audio output - Passthrough, but have also tried Auto
Infuse 6.2.3 (not Pro) - Connected through SMB (legacy, SMB1 and Auto all tried)

Test movie has played multiple times, with no issues, previously.
Encoded using Nero Recode
3,801,088,000 bytes
Codec: H264 - MPEG-4 AVC (part 10)
Frame rate: 29.970030
Audio: MPEG AAC Audio (mp4a)
Channels: 3F2R/LFE
Sample rate: 48,000 Hz
Bits per sample: 32

NAS (Iomega StorCenter™ ix4-200d)
Bonded 1GB Ethernet
Static IP address
Jumbo Frame: 9000
NFS: /nfs/Movies
SMB/CIFS: Everyone read; read/write permissions

Symptoms: same for both versions of Infuse, SMB (1, legacy, auto) and NFS
Long buffering circle to start. Plays for 2-3 seconds. Another long buffering. Maybe a few more seconds, then more buffering.

After some troubleshooting, I’ve discovered the problem as:
Netgear R6400v2 (AC1750) Router! Even though the Netgear was simply switching between the Apple TV 4 and the NAS, it caused three times slower read than write speeds (SMB1 and NFS). I connected everything to a gig switch before the router, and all is good again.

Some additional testing and I found that the Netgear was also 5 times slower to the Internet. Tried many different settings and restarts with no success. Reset to factory defaults and performance is back to the expected speed. I’m not sure what caused this or if it will happen again.