Broken MKV files - hard drive issue?

POST EDIT: Why did the title of this post changed? The original title said something like “Looks like Infuse broke MKV files after playback”. After comparing the same file which was stored in another location, I’m seeing a lot of additions and alterations when viewing them in Hex mode. Especially in the original there are chunks of sections with “00000000” value, but on the ones that were played by Infuse, they have a “03000003” in that position. But there is also ton of code added at the beginning. Not sure how that happened, but this is not looking like hard drive failure, nor even virus, since it only affected the files that were played.

Please check if your previously played files are playable.

I’ve been using Infuse since v4 I believe, now on the Pro annual subscription plan.
I had all my blu-rays converted to MKV using MakeMKV.
I noticed after a year or so, revisiting some titles that I only played via Infuse on an Apple TV 4K, that they’re erroring out, I’m getting some message like video is not recognized.
I thought first that Apple changed some libraries and those files are not compatible somehow. But testing those on Windows I’m getting the same error.

And it only happened on those files that I previously watched.
The only possible explanation is that Infuse corrupted those MKV’s
I tried every possible app/trick to repair those, to no avail. I even used MVKtoolsNix, and it shows audio only, and missing headers.

VLC shows a duration of 00:00, but the file is 15 GB long.
I opened it up with a hex editor and there are no “0” values like on other corrupted MKV as other search forums described, so the info is definitely there.

I guess in the meantime I’m going to change the permissions on all my video files to read-only.

If anybody has any suggestion that would be very welcomed.


That is quite strange. I don’t think infuse does anything other than reading files, except when file management is turned on and you delete a file. Where are the files stored?

1 Like

Yeah I’m curious about this.
MKV is all and I nuke mp4 like a plague ASAP.

Local or on Google I have 200TB and never had an issue with any mkv in infuse. I’m fairly sure Infuse hasn’t damaged your files.

They’re in an external hard drive connected to a Time Machine router

I would like to think so, but the only files that play fine are the ones that were never played before. If it’s not infuse then it’s the router.

So do you have any of those older files that you haven’t played (especially in Infuse) in a similarly long time. If so what happens in VLC?

They play fine. Is there an app that can do surface testing on a hard drive? I’m wondering if it’s damaged. I did Disk Utility first aid and it shows no errors.

Sadly I’m getting out of my depth here.

I just wondered if the issue could have been bit-rot which is apparently a thing (but not something I have personally encountered in the last 30 years.)

If the drives are not particularly old then again I’m out of my depth.
Hopefully others will chime in with suggestions.

Looking at bit-rot, not sure what to make of it, but I did change AppleTVs, that’s why I was checking some videos on Infuse to see how they play. But I doubt that has contributed to this issue.
I think after looking at all the possibilities, the fact that only un-played by Infuse media are the one still playing, I’m going to go with Infuse being the culprit for now. But I’m willing to entertain other theories.

Wouldn’t by chance be a WD external would it?

Yes it is!

Did you load the WD software on your PC?

no, it’s formatted HFS+ and connected to the Apple router

I had an external WD drive that after formatting it to HFS it started eating files randomly. I ended up reformatting it back to the NTFS and it didn’t eat any more. I can’t swear to the cause but it was showing the same thing with videos showing as 0 in VLC. I wasn’t using Infuse for that drive so it’s something with the WD and HFS formatting from what I could tell.

Thanks for that.
I also noticed the same thing with MP4 files, so not just MKV.
Weird thing is that there are many cases online with people claiming the MKVs became corrupted. If playing back is the only thing going on it shouldn’t be. I’m going to try NTFS and setting files to read-only just to be sure.

Have you tried copying a few of the files that appear to be corrupt to a new drive and see if they play from there?

Yeah, they’re not playing either

For what I can gather the header info is gone

I use DriveDx for this.

Do yo use any chance have a copy of one of the files somewhere else, that is actually working? Then you could compares hashes.