I was using aTV Flash (black) without incident until recently. Shortly after XBMC became available, I installed it via the aTV Flash menu on my aTV. I didn't see an XBMC option show up on the main screen after installation, so I thought I probably needed to restart.

I didn't know how to restart, so I held down the menu and play/pause buttons for seven seconds. The aTV restarted, but nothing came on the screen. I tried unplugging it, and after I plugged it back in, it would just sit on the Apple logo screen.

I figured that I'd messed something up, so I thought I should try jailbreaking it again. I tried running Seas0nPass, but it failed repeatedly (during the part where it tries to restore the device via iTunes).

Since that didn't work, I decided to restore to the factory OS and settings via iTunes, but, unfortunately, that doesn't work either. The restore looks like it's going to work, but then it fails with error 1601. Also, the only way I can get it to show up in iTunes is by putting it in DFU mode (menu + play/pause for 7 seconds).

Does anyone how I can get my aTV back to a functional state (factory or aTV Flash)?

Assistance is much appreciated! 

Hi bret,

You do realize the current version of the iOS (4.2.1) jailbreak is tethered, wich means you need to connect the AppleTV to you're computer every time you reboot. 

As for the 1601 error: A little bit of googling tell's me this error is related to iTunes and the iTunes and Mobile Device Support apps should be removed completely. Although I think you should try to restore first when you're AppleTV is connected to another USB port.

Good luck!



Thanks for the reply. I did realize it was a tethered boot, although I assumed that was only required on the initial boot.

At any rate, I had tried booting while tethered several times (using Seas0nPass), but it wouldn't work.

I ended up getting the device restored back to its default state by connecting the power cable after the restore in iTunes had started.

I tried several times to re-jailbreak, but Seas0nPass failed every time. I tried several combinations of having the aTV connected to power and not, including the configuration specified in Seas0nPass.

I guess I'll wait until a new release of Seas0nPass and aTV Flash (black) before trying again.

use greenpoisen to unlock your appletv version 2, and boot unteathered.  works great.  mostly.


You could try the new GP RC. But from the things I've read I decided for myself I'm staying with the current tethered jb. This is the way I do it; I connect the Apple TV to my computer, wait for the white led on the Apple TV to blink a few times. Then the led goes out for a very short moment. That's the moment when I start holding the two buttons on the remote for 7 seconds. After Seas0npass picks up the Apple TV I attach the power cable. 

Good luck!

I’m in on the GP6. Installed day it came out. Glad I did… we had a snow storm and lost power 6 times this week.
I had backed out SP when I had no network connections after reboot.

I had a weird time with DFU mode, but got it to work with JB without power plug in when running GP. Seemed easiest when I had it connected by USB only.
another trick that worked was to move the USB to different port and closing all apps and restarting

had to suffle USB ports and remove power cord too.  Weirdness to get GP to work