Bricked Gen 1 Apple TV

I am currently trying to coax a Gen 1 Apple TV back to life. It has a graphics / logic glitch (white specks all over the screen, fails to boot 90% of the time and if it does boot it displays a very old firmware menu then as I try to move the cursor down the menus it crashes and gets stuck).I can’t get the unit to fully boot and / or remain functional long enough to update the Ethernet / Wifi connectivity for a firmware update, or even scroll down the menu to select the correct option to update firmware.

It’s clearly a logic board issue. The board is functional, but needs a firmware flash.

Does anyone know of any other way to force a firmware update on these units? I suspect it would come back to life.

HELP!

Hmm…that doesn’t sound good.

You can try a Factory Restore through the Recovery menu as a last ditch effort, but it’s quite likely a hardware issue.

I bought it second hand hoping I could bring it back to life. I tried everything I could think of, but I suspect the GPU had overheated at some stage. So, now looking for a spare UK PAL motherboard from a dead unit if anyone had one. 

Shame there’s not a FOR SALE section here…

Thanks for the “Recovery” tip. I’d tried it and discovered I couldn’t get it to boot.