Bricked after installing over wrong firmware

So I have a ATV 2G and had previously tethered JB’d using the terminal method. Everytime I connected through micro-usb and rebooted using the command “/tetheredboot -i iBSS.k66ap.RELEASE.dfu -k kernelcache.release.k66”

 

Well one day I got eager and didn’t read everything and picked up the flash black. I didn’t realize that this flash black beta wasn’t compatible with my setup and I installed it. Now I’m stuck on the Apple logo, I cannot enter DFU using pwnagetool. I can’t restore. I’ve reset, rebooted, held down arrow and menu, held menu and play/pause. All the various options that used to work to get my iGear back to restore, nothing works. 

I can’t get itunes to recognize, can’t get any JB program to recognize. Any thoughts? Or am I screwed?

 

Basically my ATV2 is unresponsive unless I have HDMI and micro-usb running at the same time and I do a reset/DFU and it will reboot into stuck apple logo. That’s it. I’ve been trying to use new untethered jb’s to get something working with my ATV, nothing works though.

Anyone? I’ve searched through many threads and the Apple support and all the usual stuff doesn’t work. Anyone know how I can restore?

It sounds like you may be running an older 'tethered' jailbreak.

Your best option may be to re-jailnbreak with the latest version of Seas0nPass as this provides an untethered jailbreak for the latest AppleTV software.

http://seas0npass.com/

Anyone else have any solutions? Again,  I cannot enter DFU in ANY situation, meaning I cannot jailbreak using any method including seas0npass.

 

Actually when I get to the enter DFU part of seasonpass my USB stops working altogether and I need to reboot. DFU still no worky.

Have you tried the DFU mode suggestions here?