Brand new apple tv 2 jailbreak help

i bought a brand new apple tv 2.I opened it up and it came with firmware 4.1.1 

Since apple stopped sighning. is there a way to upgrade to a newer firware lke 5.0.2.

could i use another apple tv2 signed ipsw to use on it.

Any  help would be appreciated



Probably no because the ECID is unique to each device.

Tethered JB with 5.2.1 may be your only option now.

IFaith save blobs and JB untethered.

Wait, I always thought you can only save the blobs while Apple is still signing the specific version???

thanks i guess ill have to go the saves blobs, and jailbreak untethered for now.




unless some one else has another way


when i jailbreak it can i use the newest version of atv black on it since its version 4.1.1  ??


no you can not use it, why don’t u just save your blobs and try out the tethered 5.2.1 if you aren’t planning on moving it from tv to tv you will never notice it being tethered.


If you don’t like it you have the blobs saved so u can go back

Maybe ill try that if I can get my blobs out of it using ifaith,
Because yesterday I tried several times to get the blobs using ifaith but for some reason it gives me a message ; firmeware not supported;; so I wonder if I need an older version of ifaith


yes, it’s likely u need ifiath 1.4.1 check iclarify if you can find it send me an email so I can email you the zip.


the flash will not work on that version firmware anyway so you will have to manually install everything

For sure you can JB it with untethered. Try to save ifaith with Ifaith v1.4.2 or 1.5.5 and 1.5.6 may be you change to another computer to do that, I just JB one today with firmware 4.1.1 and IOS 4.2.1, First time i try with Ifaith 1.5.5 and can get a error Not detected IOS something, and next I tried to Save with Ifaith v1.4.2 is worked. And I use SnOwbreeze + Itunes to JB and now i have ATV 2nd version 4.1.1 Untethered.

Yes it’s brand new but I figured it out. I just retrieved my blobs with older version of I faith. Then I followed this tutorial

Then I jailbroket on 4.1.1 firmware (4.2.1)like a charm it went smooth no errors

Thanks for all the help