Boxee beta on AppleTV

Update 2/18/10: Boxee beta is now available through the XBMC/Boxee --> Downloads menu.

Do you know how to do this from windows?

Just to be clear (because I tried to follow the instructions on the Boxee forum), there is only one Applications folder, yes? On that forum, they keep talking as though there is an Applications folder and a users/frontrow/applications folder like they are two different things and I can only find one Applications folder–in users/frontrow/

It appears from this, I can simply overwrite the current Boxee.app with the one extracted with Pacifist…correct, or a false assumption?

If this file is supposed to be in another directory, would someone kindly let me know which one? I have SFTP to /mnt/Scratch set up so I can see the entire drive plus external…nowhere do I see anything resembling an Applications folder except for the one in frontrow.

Thanks

Hi All

Have tried this and it looks very good,only problem is it crashes after only a few min !!

Cameron

Having looked into this, it appears the beta version keeps clashing with a code 11 error on the Apple tv, just have to wait until a version is available for the ATV :frowning:

Cameron

There are in fact 2 Applications folders on the AppleTV, HOWEVER, if you are connected via FTP (not SFTP) only one (the correct one) will be visible.

Do you have any share points setup through nitoTV? Boxee tends to crash when accessing files via SMB.

It crashes after about 10 seconds for me. Some suggest deleting the user data, but that didn’t work for me, still crashes right after start up window appears. I also read where any external drives or network shares should be removed, and I would do that but I can’t get Boxee to stay up long enough to get to the settings. Is there another way to access the settings and be sure no extra connections are causing a loop or crash?

Also, I wasn’t real clear about there being two Applications folders (sorry). I need to FTP and SFTP into the ATV to see the correct applications folder? It would be the same one where XBMC is installed, would it not?

Thanks for the responses…all I was really hoping for was to get that stupid “need Flash 10” thing to go away on Comedy Central, but I can’t seem to find any way to install just that, plus atv flash says the plug-in IS Flash 10, so I’m stumped. Would love to get the beta Boxee working, but so far, no joy.

Well, I did a factory reset, installed ATV flash, nitoTV smart installer, did all the installs, plugins, etc. No external hard drive connected, no sharepoints. Deleted Boxee.app and user data, FTP’d beta Boxee to the Applications folder.

Started up Boxee, went through log in, 10 seconds into loading main window, crash. I’d be happy to post a console log (or whatever), but everything I see about exit on Error: 11 says delete user data or make sure there are no share points (including here). Neither is an issue, but the sucker won’t run.

Brand new ATV (had it a week) running 3.0.1, ATV Flash 4.0.5. Any and all suggestions for alternatives welcome.

It’s running OK for me, and accessing SMB shared drives …
Just followed the install instructions here:
http://forum.boxee.tv/showthread.php?t=14664
And used CyberDuck and Terminal to do as required.

Hi, I have tried to extract the Boxee.app from the .dmg file on windows without success.

I have tried to use BoxeeBetaInstallScript.sh but the command prompt just freezes and I get no response.

Any help please?

thanks.

wow finally got this working after 10 or so tries, with the code 11 problem every time.

not sure how though :slight_smile:

  1. made sure it was in /applications/
  2. disabled the web server

works like a charm so far, about 30 minutes with no code 11 crash!

If I may ask, which procedure were you trying? FTPing the Boxee.app file or following the procedures on the Boxee forum?

this procedure (FTPing the boxee.app to /applications/)

background info as it was a bit weird

  • new apple tv

  • newly flashed atvflash

  • removed all trace of boxee alpha from previous install (including shortcuts)

  • uploaded beta boxee.app to /applications/ AND to /users/frontrow/applications/ (i was trying anything)

  • restarted the apple tv

  • started boxee beta on the atv (expecting it to crash after 10 or so seconds)

  • as it was starting up, i went into settings and disabled the web server

and it just worked. hasn’t crashed at all so far, been up a few hours and i’ve watched a few things so far with no problem

Hi,

I am having the same issue with the code 11 bug. I FTP’ed my Boxee in. Any suggestions?

Billy

What’s the big advantage of the Boxee beat over Boxee alpha? Alpha working fine on my ATV, and beta sounds like a real PITA to get installed…just my $.02

I tried the exact steps on the tutorial but whenever I try to launch Boxee I get this message:

“Error: Cannot launch XBMC/Boxee from path:
//Applications/Boxee.app/Contents/MacOS/Boxee”

Help would be appreciated.

Thanks for the guide. I tried what you said exactly but I still get the same error message:

“Error: Cannot launch XBMC/Boxee from path:
//Applications/Boxee.app/Contents/MacOS/Boxee”

Any ideas?

Thanks in advance,
CG19.

This all seems tedious. I thought I purcahsed an application that took care of script writing, removing and updating application and could allow Adobe flash player v 10 to install. I jsut don’t have the time to expeirment and come up to speed on doing all of this. Very disappointed in this product.

Boxee beta is not officially available yet for the AppleTV. The instructions here describe how to install the standard Mac version…some feature will be missing when installed on the AppleTV.

The official AppleTV version of Boxee alpha can be easily installed through the XBMC/Boxee --> Downloads menu.