Boxee Beta Can't Play Online TV Shows on Apple TV

Since upgrading to Boxee beta I can no longer watch TV shows (except from my local server) and other video that I once watched using alpha on my Apple TV. Suddenly I kept getting the error 11 message everytime I logged in and the everything froze and I had to reboot my Apple TV. Everything works well from Beta on my Mac.

Frustrated by this, I reload my Apple TV to the factory settings and reinstalled everything (iTunes media, ATV Flash and Boxee). I still can not view TV Shows I once could (Perry Mason, etc) or any other TV Show, including Boxee. All I get is a white screen. Some times the video began to play the commercial then suddenly a blank screen, although the timeline display indicates the movie is playing. This happens whenever I play any video that not on

Please give me some direction here. I’ve been trying to get this to work for the last 3 days and am not getting any results. Do anyone have a solution? Also, is there a way to delete Boxee (or any program) from aTV Flash without using a terminal or console? I not a tech geek (that’s why i purchased ATV Flash), so if I have to enter or look for code, please be specific.

I running the latest Boxee Beta, with Apple TV OS 3.0.2.
Thanks in advance for your help.

To fix the error 11 in Boxee Beta, all I had to do was to remove the following directories (with commands):

sudo rm -rf /Applications/Boxee.app/
rm -rf /Users/frontrow/Library/Application\ Support/BOXEE/

If you are afraid of the terminal, you can use muCommander on Mac OSX, Gnome Commander on Linux and either WinSCP or Total commander with the SSH plugin on MS Windows.

For your other issue, did you rerun the smart installer after restoring?

Yes, I reran smart installer several times after restoring but are getting the same results.

Please forgive me for sounding like an dunce, but I do I run terminal from my Mac or can I do it from ATV? If so, where do I find terminal or issue the command on ATV? I’m assuming that I would have to enter onto a patch drive or is there’s a way to connect my Mac to ATV?

Again, thanks for your help.

You should probably do it from your mac, just:

ssh frontrow@“AppleTV IP adress”
and then you run the commands above.
To quit, you just type exit.

Thanks for the advice. I entered the code through terminal per your instructions, but I’m still not able to watch video other than from my own iTunes library. I used to be able to watch CBS and Hulu links under alpha but still nothing (except something the commercials). I surf the Forum and tried every work around posted but nothing seems to work. Sometimes I may get a video from the TV Shows Library to start playing, but it eventually gets hung up and I only see a blank screen, no video or audio.

At least I’ve learned how to use the terminal to update Apple tv. Please let me know if you have any other solution.
Thanks.

I’ve got the same problem since upgrade to AppleTV 3.0.2 and upgrade to the Boxee Beta.

When you try and stream video, you just see a blank screen, with a frozen boxee progress boxes. If you exit back to a menu Boxee shows you in the top right the time/progress through the file but you can’t see in on the screen.

Can’t find a solution at the moment.

Fails to play everything I’ve tried to stream so far.

Fixed! :smiley:

Not sure if you’ve got the same problem, but when I tried “Smart Installed” it kept saying partial or failed install, so
I’ve done a complete factory restore and reinstall and it’s solved the problem with Boxee Beta streaming.
Deleting Boxee and reinstalling it alone didn’t work.

Follow sterlingjbadon instructions on the link: http://forum.atvflash.com/viewtopic.php?f=19&t=2490&start=30

I to am having the same problems. Boxee beta does not work at all on the apple t v. I have completely wiped atv 4.1 and factory restored the apple tv to factory then reinstalled atv 4.1 and and boxee beta from scratch and when I play streamed content from cbs or any other network I get a white screen when the video plays and no sound. checking the progress bar I see minutes counting out but no picture and no sound just a white screen. I reinstalled the alpha and boxee works just like it used to are there any fixes for this I really like the new menu but without being able to watch the shows its really useless.

Did you install Flash properly?

http://forum.atvflash.com/viewtopic.php?f=18&t=2629&p=11098#p11098

Many Boxee video feeds will require Adobe Flash. There is a guide for enabling it here: http://wiki.atvflash.com/index.php?title=Enable_Flash

I have been having the same issues since the latest update. I had Flash before update, but now I don’t. I have done EVERYTHING that you have suggested on this site as well as what is discussed on the Boxee forum. Is there a system report I can run that will possibly help you or someone else figure out what the issue is?

Same issue here. I’ve tried everything on this site (including the Flash CoreAudiokit), and all I get on Boxee is a black screen and a time bar indicating the video is playing but no picture and no sound. I did a factory reset, update, installed ATV flash 4.1, placed necessary files in the Documents folder, ran smart installer, installed all the plugins, went straight to Boxee beta for install instead of alpha.

No joy with Boxee no matter what I do, but at least it isn’t crashing any more.

If anyone has any ideas, I, too, would love to hear them.

I agree. The biggest problem with getting Flash on ATV isn’t the process itself, it’s the fact that there are dozens of threads explaining different ways to get Flash working. I would appreciate one thread stating the current method that works. According to the Boxee forum all you need to do is just install Boxee Beta and you’re done… That doesn’t work.

The simplest way to enabled Adobe Flash can be seen here: http://wiki.atvflash.com/index.php?title=Enable_Flash

What kind of guide starts out with:
“1. Using Cyberduck or WinSCP, transfer the CoreAudioKit.framework via FTP to the Documents folder on the AppleTV.”

This is about as helpful to the average user as saying:

“1. Install Flash on your ATV.”

Are we being punk’d here?

Does anyone actually have a REAL guide?

Boxee can be installed without enabling Flash, but some streaming videos in Boxee will require Adobe Flash to be enabled.

You aren’t missing much. I can play them, but they aren’t worth watching because everything plays at about 5fps.

I’m not sure what the point of developing Boxee for the ATV is. At this frame rate, it’s too annoying to watch anyway.

Again, I don’t know how much more simple I can say this, I have done EVERYTHING (including this link) that this site and the Boxee forum have said to do to get Flash working. FLASH WAS WORKING FINE FOR ME BEFORE THE 4.1 UPDATE.

Please understand that the majority of people reporting a problem have the following issues (I know as I have read everything on every site):

  1. Used ATV Flash and not the other patchstick to install Boxee/XBMC (most people using the other patchstick do not have a problem)
  2. Had Flash working properly using the CoreAudioKit file before the Apple 3.0.2 and ATV Flash 4.1 updates.

And most importantly #3 - Have used your guide to try and get Flash working properly again and it just isn’t working. Even the people at Boxee have stated that you must be using something different because they can’t figure out why Flash isn’t working either.

The key component required for Adobe Flash is the CoreAudioKit.framework from an Intel Tiger system, without this Adobe Flash will not work on the AppleTV. This framework file is not included in any of the aTV Flash install options, and must be located elsewhere.

Once located, it can be installed on the AppleTV by following the Adobe Flash guide mentioned above.

I could be completely wrong here, but I think aTV Flash is prevented from helping us with the CoreAudioKit.framework because they are charging for the aTV Flash solution, and they would be at risk if they provided the apple proprietary code. Of course, the free patchstick solutions out there don’t have that problem because they’re free and not liable for damages in a lawsuit.

So aTV Flash is kinda stuck. To get flash installed properly, aTV Flash paid customers have to do some real hacking, which will involve getting the framework, copying it to the right place, and then running “install flash” from maintenance. It doesn’t always work, trial and error may be required. Even if you do get it installed, I’m not sure that it will be the version 10.x that’s required for hulu on boxee. And even if you do get the right version installed, hulu and other major network streams are very choppy on the underpowered AppleTV processor. This problem exists for all AppleTV users, whether they’re using aTV Flash or the free patchstick.

I can see how it’s frustrating though, and I’m frustrated too. The aTV can somehow stream HD movies and flash via YouTube, but it chokes on Flash from hulu? Why does youtube work and not hulu on boxee? For that problem, I’m leering at boxee, which unfortunately seems to have de-emphasized their appleTV development.

So there’s my take on the landscape right now. I’m just being patient and waiting for it all to work out. In the meantime, I can download whatever I want and transfer to the aTV for viewing.