Bought an ATV with 4.3.0 (2557) on it

I found an ATV2 that reports as having 4.3.0 on it.  When I start Seas0nPass, right click and select one of the 4.3.0 builds it just sits there and does nothing.  Is it possible to JB 4.3.0 following one of the procedures laid out in the forums?  Do I need to do all of the rebuilding of the ipsw with TotalCommander etc to get it signed?  Any help would be appreciated.

So now I have:

ATV2 with 4.3

ATV2 with 5.1

ATV3 with 5.1

All waiting to be JB :-/

Yes you will need to rebuild the IPSW because Apple is no longer signing the iOS 4.3. 

OK two questions on the process in this forum thread - http://forum.firecore.com/topic/7279

  1.  It says to download the 4.4.4 ipsw.  Is that ok or should I download the version on my device 4.3.0

  2.  When I connection this apple tv to TinyUmbrella it reports 4.3.0 but only saves an SHSH blog that refers to 5.1, does that make sense?

I’ve never been able to get iFaith to recognize that my devices are in DFU.  Even though windows reports Apple Device (DFU mode).

please save your blobs and share file in 2share.com to help us study this version

 

after go to 5.1 with itunes

 

and return teethred on 4.4.2 … many guys succeeded it

Sorry, just saw that the procedure says “or alternate version” so I’ll work with that.  Still don’t think I’m getting the proper shsh blob saved though.

Ignore my ifaith issues too.  Didn’t realize it relies on iTunes drivers.  I’ll report back with my success or lack thereof.

Just be sure not to update the iOS. 

Gotcha.  I’ve gotten further.  I got ifaith to save my 4.3.0 blob (it aborts early on the 5.1 device).  attempting the rest of the process shortly for my 4.3.0 device.

Actually, have another question.  How do I figure out the url for the 4.3.0 ipsw?

The equivlanent of this prerequisite step:

Apple TV 4.4.4 9A406A Firmware (http://appldnld.apple.com/AppleTV/04…a_Restore.ipsw)”

 

http://appldnld.apple.com/AppleTV/041-0895.20110728.TcF4T/AppleTV2,1_4.3_8F455_Restore.ipsw

Yea shoulda googled first.  Sorry, but thanks for all your help.  Getting excited/anxious now :slight_smile:

Next question, sorry, I’ll update the thread when I’m done to add more clarity.  getting ready to start Part 3.  In this case Seas0nPass is going to try and download the latest 4.4.4 I believe.  Is this ok? Or should I right click here and select 4.3.0?  In the past when I’ve done that it still appears to download 4.4.4.

No problem. Good luck and post back with your results :slight_smile:

Success!!!  Got this ATV2 with 4.3.0 (8F455) jailbroken, signed, flashed and atvflash-black’d.  I’m rockin.  All hail firecore!

Now if I can just get my ATV2 and ATV3 with 5.1 done, I’ll be golden.

Thanks again guys!

Glad it worked!

 

can you share with us your 4.3 blobs ?

I have the exact same problem as the op.

I bought a atv2 4.3 (2557) - tinyumbrella saves the blobs as atv2 5.1 (9b179b)

I cannot flash anything on that device. Whether its a cfw or the original one from Apple doesnt matter.

Here is what i have done so far and what happens:

  1. connected atv2 and put it into dfu mode (usb view shows recovery mode)

  2. saved my blobs with tinyumbrella

  3. checked ‘the request shsh from cydia’ box

  4. started TSS server

  5. started itunes

  6. clicked shift+restore and picked custom firmware or original (this doesnt matter it always happens the same)

and then what happens is itunes shows ‘preparing apple tv for restore…’ and then nothing happens for like 5-8 minutes. then i get error 1604.

i tried the following ofw’s:

AppleTV2,1_4.3_8F455_Restore.ipsw

AppleTV2,1_4.4.4_9A406a_Restore.ipsw

and the following cfw’s:

sn0wbreeze_Apple_TV_2-4.3-8F455.ipsw

AppleTV2,1_4.4.4_9A406a_SP_Restore.ipsw

 

The outcome is always the same.

When i put my device into the pwned DFU mode with iReb itunes runs into error 2005 until i replug my atv2.

I already tried three different microUSB cables on three different computers and on each i tried every freaking usb port and the outcome is always the same.

I am kinda stuck here. Any help is appreciated.

I just did a 4.3 one… you need to build the IPSW as in the sticky about 4.4.4

JB ATV2 with 4.4.4 installed - after apple stopped signing

 

although I found these instructions clearer;

http://spoonjab.com/updated-jailbreak-apple-tv-2nd-gen-4-4-4-9a406a-ios-5-0-1/

i.e. use Faith first to obtain your Blobs and save them

 

Try to then use iFaith to put into DFU as per the last instructions in the 4.4.4. thread, and restore using the amended IPSW that is now signed and jailbroken.

 

(I found that it didn’t complete properly and was stuck in DFU - I then did an iTunes update to 5, then ran iFaith again to use iReb and did the restore and it was ok)

 

ATV2 on 4.3 - iReb put it into DFU and it won’t come out

 

ok, thanks for that tip.

i managed to flash it with a jailbroken 4.3 fw file.

but how do i build a signed 4.4.4 with ifaith when my device is still on 4.3.0? since i cannot upgrade my device to ofw 4.4.4 with itunes.

As far as I know you cannot build a signed 4.4.4 release if you do not have saved blobs for your device for that release.