Blank library on some devices

Hi - I have my Infuse library sync via iCloud. It is showing up correctly on my Mac and my iPad. However, my iPhone and my Apple TV are showing up blank. I deleted the apps and redownloaded. The apps identify correctly that I am a Pro user. And iCloud syncing is turned On. I tried toggling the setting ON and OFF (on both the iPhone and Appel TV). It says syncing library but within a second it shows the library to be empty on both these devices.

I have verified that Infuse sync is turned ON in the iCloud settings. Tried toggling that as well but it didn’t help.

Some background - my toddler reset my Apple TV to its factory settings. So I had to reinstall the App. I thought the library would sync in some time, but it didn’t. The last sync time always updates to the current time and becomes blank. I think the iPhone is now syncing to the blank AppleTV library, while the Mac and iPad are syncing the correct database.

Any help would be appreciated.

When you launch the Infuse app on the Apple TV and go straight to the Library settings page where it shows the numbers of movies and tv shows, it also shows the status messages of what Infuse is doing. What does it say for the status messages?

AppleTV library settings page says ‘Last Update: Today, 7:37PM’. Which is the current local time. Above it, it says Movies: 0, TV Episodes: 0, Other: 0.

On the right, settings are - ‘Show library’ (this is ticked). Below that ‘Scan for Changes’. Clicking this just updates the Last update time stamp on left. Below that there is a refresh Metadata which gives a warning for taking considerable time. Hitting continue does nothing. Finally, there is ‘Sync with iCloud (last: Today, 7:37 PM’). Clicking that the time stamp on left changes to ‘Syncing with iCloud’ briefly. Then the time stamp on the right updates to the current time. But library remains empty.

On the main settings page - iCloud sync is On. On the left the app icon does say ‘INFUSE PRO’.

Pretty much the same behavior on the iPhone. Needless to say, all devices are synced to the same iCloud account.

First, what protocol are you using to connect to your server? FTP SMB DLNA UPnP ?

Next, do you have shares checked to be included in your library?

It sounds like you don’t have any shares selected to be included in your library with it saying

I have the same problem.Movies and TV shows in my Apple TV have become 0.I need to re-enter the storage space through the directory, and browse through each directory again, and the data in the movies and TV shows appear again.
But after a short period of time, usually a few hours, the number of movies and TV shows goes back to 0.This problem bothers me a lot.

by the way,There was no problem at all before, but the problem occurred after updating the latest version. It has been more than a week

Can you check to see if any shares are present on the Apple TV in Infuse > Settings > Shares?

What type of device are you streaming from?

Are you using a media server such as Emby, Plex, or Jellyfin?

On the Apple TV, the most common issue we see related to iCloud Sync is having a different user account set up as the ‘Default’ user (or having no Default user set at all). This means the account used for syncing may be different than what your other devices are using.

You can check the Default user in Apple TV > Settings > Users and Accounts.

Thanks for the input. The issue was that I was using Plex media server. I didn’t realize I have to relink Plex individually on all my devices. I thought that if Plex is linked via one device, the Infuse library will get populated and then sync to everything else via iCloud. Seems that’s not the case. One has to ‘add media server’ to all devices individually. So it was indeed user error on my part, though to be fair I don’t think this is explicitly mentioned in the documentation or help. Maybe a line in the app saying - ‘If you are using a media server, relink it to each device’ (or something to that effect) will be useful.

Thank you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.