Black screen with DoVi P8 on Apple TV 4k 2022

Movie DV files cannot play on my infuse installed on my apple atV 4k. But the files are working on VLC and infuse installed on my ipad. Any setting i am missing here?

There is sound but no video.

Check the “Extended Dolby Vision” setting and try the different settings.

@NC_Bullseye , do you recall the thread where this was marked solved with one of the recent updates?

I’ve encountered this situation for the first time with some 4K DV episodes of “The Mandalorian” Season 3 and “Hello Tomorrow!” I recently watched (the latter of which had previously played without issue).

For me, the audio without video issue is occurring on my iPad (9th gen), but not my older AppleTV 4K (1st ver.)

— but that is likely explained by my iPad running a newer version of Infuse (though not the newest) than the Apple TV, due to my current lack of home Internet and the resultant difficulty keeping their software current.

If I recall correctly the issue was discussed and, I think, resolved in a subsequent update?

  • I of course did toggle through all the DV options without success (on the non-current software).
1 Like

Yes there was a regression just recently with the black screen.
It only affected profile 5 and was fixed in the last beta.

1 Like

Yup, that’s the reason I suggested going through the settings since if I recall correctly for the files that were audio only would play correctly with “Extended Dolby Vision” turned “Off”.

Including “Off”?

I think so but of course I will try again and edit this post momentarily.

[Edit] Included update in my reply to James below.

[2nd Edit] Posts were moved to a new thread, linked below.

Can you check to confirm you are running the latest 7.5.5 version (scroll to the bottom of Infuse > Settings).

If you are running 7.5.5 and seeing a black screen, we may need to take a look at one of these files. If possible, uploading a sample would help us greatly in tracking down the issue.

Files up to 50GB can be uploaded here.

6 posts were split to a new topic: Dolby Vision not working on 9th gen iPad

@james yes i am using Infuse pro 7.5.5

I will be sending you the file sample for checking. Appreciate if you can look into it. The problem persists on Apple TV 4k only. No issues on my Ipad


I kind of hijacked your thread (my issue was iPad related on an older OS), so I just wanted to draw attention back to @NC_Bullseye ’s suggestion here.

hi @FLskydiver, thanks but I already tried different settings from Infuse including the Extended Dolby Vision options and also Apple TV settings before I posted my concern and I’m still getting the same problem (No Video with Sound) .

I’m looking forward on @james if they already received the sample file I sent.

No worries, just wanted to make sure you saw it.

And to be clear, you are utilizing also the latest 7.5.5 version of Infuse and the latest version of tvOS?

[Edit]. Just saw in
your photo that you are on 7.5.5.

Sample received, thx! Will be looking into this.

thanks @james. have we checked on it?

You want him working weekends? :stuck_out_tongue_closed_eyes:

Oops my bad, not my intention… take your time :grin:

1 Like

still not resolved as of this moment. oh well :man_shrugging:

1 Like

You want him working summer months, now, too? :grimacing::speak_no_evil::zipper_mouth_face:

Still unable to watch DV on my 9th gen iPad, but didn’t realize this issue is still affecting you on your AppleTV. Hopefully it just got lost in the noise and your very patient 2nd bump is enough to get Firecore to take another look. :crossed_fingers:t3:

Apple is adding official support for Profile 8 in tvOS 17 and we are working to integrate these new features.

This may help resolve some issues like this, and we’ll evaluate any remaining issues after this transition is complete.


Hi everyone,

I’ve been encountering a peculiar issue with Infuse while trying to play DV (Dolby Vision) files on my LG 4K TV through Apple TV 4K (2022). When attempting to play these files, Infuse displays a blank screen, but I can see the video preview when I scrub through the timeline.

I’m hoping someone in this forum might have some suggestions or solutions to help resolve this problem. Your insights would be greatly appreciated!

Apple TV: 4K (2022)

Thank you in advance!