Black screen after trying to set USB drive as Primary

Hope someone can help with this. I followed the instructions for setting my 1tb USB drive as Primary and when I came back to the ATV after it had copied the files over I had a load of script on screen that seemed like error messages. Also the led was flashing amber. Tried to hard reboot and got the same code on screen.
I unplugged the USB drive and restarted again. This time I get the welcome screen & sound then the screen goes back, but the unit still receives commands from the remote as I get the “pop” sounds, I just can’t see anything.
I’ve tried diagnostics, it reports everything ok. Tried factory restore and that just takes me back to the “Diagnostics/Restart/Restore” screen. Tried setting a different resolution, I get all the options but as soon as I select one the screen goes black again.
I’m running on ATV firmware 3.01 and ATV Flash 4.06. I can still SSH into my ATV via Cyberduck but the unit does not show up in iTunes anymore.
I’m running out of ideas now. I’d just like to get back to my internal hard drive as primary storage and start to use the ATV again. If anyone can give me any ideas on what else to try, maybe a terminal command to reset the internal drive or something, I’d really appreciate it.

Sorry folks. After hours of trying to fix this I posted here for help then tried one more thing. I powered down the USB drive and the ATV, reconnected the drive and powered it up, then powered up the ATV and Bingo! Everything is good. All my content seems to be synced and it’s showing up in iTunes as a 1tb drive. Panic over!

Glad it’s working for you. I was about to post the exact same recommendation :slight_smile: