Best way to share files from a Mac running Ventura?

I previously had good luck on my old Mac sharing files to Infuse on my AppleTV, via (I think) SMB.

But my old Mac was really old, and can’t run the latest OS. So I upgraded to a machine that can run Ventura.

Trying to allow sharing of my folder of movies, on the new Mac, is proving challenging.

The instructions on the FireCore site just point to Apple’s own help pages. Okay, so I followed all those steps…and no dice.

InFuse can see that I have this Mac on the network, and acts like it is allowing me to connect. It even sees the one folder that I have shared. I input my username and password…and try to open the share, or run a speed test, and get a “An error occurred. Sorry, Infuse encountered an error while trying to connect.”


For reference, on the Mac running Ventura, under General > Sharing I have selected File Sharing = On. I have confirmed that the Media folder is listed as a Shared folder. I have made sure the user for this purpose has both read and write access to that folder. In the Advanced menu I have made sure that the folder being shared is using SMB. I have made sure I have applied permissions to all the enclosed items (in the folder).

I have also tried sharing the whole drive, just to see if that helps. Same thing happens.

What else should I check?

I’m not wedded to SMB. It was just what worked the last time under the old OS, so that is the path I’ve gone down with Ventura too.

Have you tried not entering a username and password?

Or trying to set a unique one for the shared folder?

1 Like

In Infuse if I won’t put a username and password, I can’t even add the Share. (So I get even less far.)

I’m not sure how to password protect a single folder in Ventura. I simply created a dedicated user for media sharing purposes, and gave that user Read and Write ability for the whole drive the media content is on (in permissions, in Ventura).

But if you have a pointer to how to do it the way you describe, I am ready to give that a try.

Unfortunately, I don’t — I’m not a Mac user, and I normally use NFS these days.

To verify my memory on the passwords, I turned on my old WD MyCloud NAS and went to Infuse’s Shares page and waited for the list of Available Shares to populate. My WD NAS popped up by both its share name and device IP.

I selected the share name and the next screen showed username and password fields prepopulated with “johnappleseed” and “password” — definitely not any username or password I ever used to connect to my NAS — I believe these to be Infuse’s defaults.

I didn’t modify them and left them alone.

(Curiosity had me click the username field and the prompt asked for an email address; which seemed odd because the prepopulated username isn’t in the form of an email address such as john@appleseed.com.)

So, leaving those fields as they were, I scrolled down to select Save and my Infuse directly connected to my old NAS without issue.

When I’d above suggested trying to connect without using usernames and passwords, I should have specified I meant simply not changing the fields at all.

Trying to connect to the IP address version of the WD NAS share didn’t work (as I likely had disabled NFS on that device).

That resulted in the same error you saw:

“An error occurred. Sorry, Infuse encountered an error while trying to connect.”

I had to connect my Synology shares (by IP address) via NFS by using the “Other” shares button; that allowed me to enter the username and password I specially setup to protect that share.

How many items appear when you select Shares under **Available Shares”? Do you see the share identified by both its share name and its IP address?

If your MAC has NFS, you might try that; or WebDAV, or FTP. Sounds like a lot of people do well with FTP.

I don’t know how you check on a Mac but you’ll want to verify whichever protocol you choose to connect with is enabled in the Mac or for the Share.

The one specific you don’t mention is “Windows File Sharing”. I just moved to a NAS but used to share files with my Ventura MBP. You need your account set up to use it. It’s under File Sharing options. Mine is still set up that way, although I have nothing to do with Windows.

Alternatively, this might be a rather common Ventura SMB problem. The below thread says turn off file sharing, reboot, and then turn file sharing back on. This apparently worked for many.

https://discussions.apple.com/thread/254343578?answerId=258164570022#258164570022

Here’s another link @james posted with similar (but different) steps that I successfully used not long ago.

1 Like

Thanks. Yes, I should have mentioned that I turned the Windows aspect ON, as well.

This idea of restarting – with it not enabled, and then enabling it. INTERESTING! I’m running some other processes as part of setting up this computer, that I cannot interrupt for a while, so I can’t test it immediately, but thank you for pointing it out. I will give that a try.

1 Like

Thanks for this additional detail.

Okay, I deleted the Share in Infuse, and then went in to Add Share.

I see the Mac listed there under Available Shares. I choose that one. And I don’t change /enter anything into usernames and password.

I get “An error occurred. Your username and password combination isn’t right. Please try again.”

which sort of makes sense since I don’t have sharing on the Mac setup to allow just anyone to read/edit/delete things on my media drive.

(For contrast, if I enter my media user name and password, things work well enough that the Share works in that it shows me the top level folders, etc, and I don’t get that error about usernames and passwords. But trying to actually open those folders, to get to content, results in an error.)

I’m not running FTP or HFS or WebDAV, but if following the advice to turn off and one file sharing between a restart doesn’t help, those may be my next stop.

So “frustrating” that I can connect to the Share at the top level, but not browse to lower levels in the Share! :wink:

Much appreciate the ideas you have suggested.

1 Like

I always used my MBP user name and password when creating a share to the MBP. Is that what you meant? Maybe you have it set up differently…

1 Like

I have multiple user accounts on my Mac. I have one specifically set up for media sharing. And it authenticates okay from Infuse, and sees the main drive it has access to…it just can’t get below that level to actually see the content via Infuse.

That didn’t seem to be a problem with my last Mac.

I would hate to have to enter my Admin credentials into InFuse. Not that I don’t trust Infuse, per se, but I don’t trust ANY app on any device with my Admin credentials.


I am cautiously optimistic a restart may help. But I cannot restart the machine at present due to other processes taking place.

2 Likes

I’m running ventura on an iMac and Infuse does what you did, it has a media player name and pass it uses to access files on the imac with no access to the rest of the macnine. It can be done, so hang in there. :wink:

1 Like

Thanks. Yes, it should work, and I am glad to hear that you have it working, to confirm that.

Can you share how you did your setup? SMB? Created a dedicated user in the user accounts? Etc.

It’ll be a bit before I get to that machine but I’ll check when I do. :wink:

1 Like

You can use a shareware app called NFS Manager from Bresnick software (I think).
I used it to set up NFS share for my two Drobo volumes attached to a mac mini running Ventura and it works fine. Originally set up 2 OS versions ago for the mac. It works fine under Ventura. The Mac has NFS but the app just makes it simple to enable.

1 Like

Thanks for the recommendation. Hopefully I don’t have to go down that path. I hate using shareware to mess with OS level access stuff on principal! But I know sometimes such things are needed.


Update: I just removed the File Sharing from the system. And changed the password for media user. Then I re-enabled Sharing. And tried to share the media drive with the media user AND tried to share another drive with another user. The media user ended up being able to see all the content of both drives (the one they were granted access to AND the one that they were not) which was not a nice result to see. But then I killed the second drive sharing and the media user still retained access to the media drive this time!

So, the solution was: Mess around with enabling and disabling access, changing passwords, adding other files to shares, and other users to other shares, and then removing some…and then it worked.

That’s not REALLY a solution. All the settings I started with that didn’t work are now the exact same settings I have that DO work. (Okay, I shortened the password from twelve characters to six, so that is different.) But it is what I did, and now it is working, so… I blame Apple’s OS. Seeing how Infuse was able to correctly supply the right password and authenticate but not navigate and read contents until I messed around with the Apple side of things has convinced me where the errors are coming from.

1 Like

Well, isn’t that annoying? :triumph:

Glad you’ve got it working now. Take a few days off, retrace your steps, and maybe you’ll figure out why it finally started working. Or maybe you don’t do that, and just enjoy using Infuse!

(I really wish I was the sort who could just let things go and do the latter. :upside_down_face:)

It is very difficult to determine. My working hypothesis is that deleting and recreating the Share on the Mac is probably the key.

1 Like

There is no point in doing all that. Back in the day I was going to use the sharing folder method but decided to go with Plex.
Plex is the way to go.
Then you connect Infuse to Plex.
If you use custom artwork, then you have to follow Plex naming parameters instead of Infuse’s.

Plex = Good Library, Ugly Player
Infuse = Good Player

That’s an interesting idea. If it remains unstable or unreliable, I will give that a shot.

Plex Media Server really does work very well with Infuse and is easy to setup. I’ve seen plenty of people suggest it as the ideal combination, and they might just be right.

The other suggestion above, to use NFS, is also a good one. The software mentioned, NFS Manager (which is free to download and use), can be found here: NFS Manager: Description

NFS in built in to macOS but there’s no easy way to configure it without using NFS Manager. It’s basically a one-time setup and you’re done.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.