Best setup to play 720p MKV from a hard drive without buffering

My movies are on an external USB2 hard drive plugged on a First Gen Time Capsule to make it availaible on the local network.

The problem is that Media Player (or XMBC player) is Buffering very often, specially with high bitrate 720p movies (4.5Gb for 2 hours), 1080p also…

My Jailbroken ATV2 IOS 5.01 is connected with ethernet cable to my Timecapsule. I access the shared folders through AFP protocol.

So, i m trying to find a better setup to improve the network speed to be able to watch 720p movies without buffering.

I was looking for a NAS with high transfert speed rates to host my video files but maybe you guy have better solution to improve 720p videos playing ?!?

Thank you.


I am able to play these formats over wifi with media player… My PC acts as the server alongside an external hard drive. Perhaps there are some settings that need tweaking? Very odd that you’re having issues while wired directly to the time capsule. Strange idea but try it wifi and see if its any better.

Hi gobi13,

It sounds like a bottle-neck issue with throughput on your ad-hoc network.


Using a USB2 External Drive <==> Network Device <==> aTV can be a very bandwidth-intensive operation that, most likely, requires as much speed as your Time Capsule can offer.

If you can, try using the IP address for your share (whilst using AFP) and not “mytimecapsule.local” as this eliminates Bonjour as a source of problems.



Thanks for the help timeimp!

I used the IP address to link my share (keeping AFP protocol).

It seems more fast but i still can’t watch a 4.5GB 720p movie without buffering each 5-10 minutes : 

Video Codec …: x264

Video Resolution …: 1280 x 544

Video Bitrate …: 4 610 Kbps

Audio …: French DTS 1509 Kbps 

My network speed is enough to play that movie on a computer but not on the ATV2… 

Can the ATV2 play a 6000 Kbps (video+audio) movie over a gigabit network ?

Is there a way to test the performance of my LAN from the ATV (via SSH) ?

Thank you!

This will sound odd… but try WiFi.


The Ethernet Drivers in this update are apparently borked, and because iOS 5.1 has not been jailbroken yet, Ethernet will have issues. What you are most likely experiencing is packet loss, resulting in the 5-10 minutes of buffering.



I just tried WIFI connexion between my ATV2 and TimeCaps that are really close on the same table and it works well !!! Finally I can watch a hight bitrate 720p or 1080p movie without buffering ! I tested watching a 4.5Gb, 2 hours 720p and even with a 1080p 13Gb movie, I experienced no buffering during the Action scenes which generally use a higher bitrate…

So now I ve to figure why my ethernet setup was not good, i ll try a another cable to start… If I could use a command line test to benchmark the connexion between my ATV2 and my TC HDD it could be helpful… Should I try to copy a file on the ATV2 Flash drive to measure the speed ? Somebody ?

If you simply use Time Capsule <=(ethernet)=> Computer and playback a file that you were having issues with before, you will be able to determine if your Time Capsule is at fault.

Most likely, it is your AppleTV. You can test this by plugging in Ethernet into the TV (like your normal setup) and going:

  1. Open Terminal (~/Applications/Utilities/
  3. Watch the results and wait around 10 seconds.
  4. Press CTRL+C to stop. (NOT COMMAND+C)

This ping tool will show a very high packet loss (>5%) in the summary. This will mean that the Ethernet on your AppleTV is borked.

This AppleTV Support Article should help. Note the OS 5.1.1 update, under Stability and Performance.



Mine says:

— ping statistics —

49 packets transmitted, 49 packets received, +241 duplicates, 0.0% packet loss

round-trip min/avg/max/stddev = 0.491/54.524/320.841/91.796 ms


I ran this typing on my computers terminal the pin + the NAS IP.

So I guess 0.0% means the Ethernet is Ok, right?