Banding / posterization artifacts with 10-bit SDR files

Severe banding playing anime files in Infuse Pro ATV 4k. Attaching a few screens comparing how Infuse displays the video stream vs the native tv media player. Will attach the the media info in a subsequent reply or a post exit.

Here is a link to the media info:
media info

Judging by the mediainfo file, this video has a very low video bitrate. And this indicates a large compression of the file. This leads to image artifacts.

You missed the part where I explain I am comparing the same file with the internal native media player of the tv. If the problem was with the file it would also manifest there. VLC on tv os also handles the file better than Infuse.

Can you check to ensure the Match Content options are enabled on your Apple TV as described here?

We recommend keeping both options enabled, as this will allow Infuse to adjust the video output to match the content being played.

Thanks and yes: both options are enabled.
ATV is set as SDR 4k 60.

You may also try adjusting the Apple TV’s Chroma setting to see if this makes a difference. I know at least a few users were seeing strangeness when anything other than 4:2:0 was used, but IIRC this was only affecting certain TV models.

If the issue persists, we’d love to take a look at one of the problematic files if you are able to send in a sample. Files up to 50GB can be uploaded here.

Tried that as well, tried setting it to rgb high, then low etc
Since for example VLC does a better job at rendering the file I tend to think Infuse has more to do with it. I will try to play it through Emby as well.

I’ve uploaded the file. The screens were taken starting from 20:50

Thanks for the sample.

We’ll be looking into this.

I’ve encountered this again today. I’m tempted to try the Martian next, but really any content with soft gradients exhibits banding / blocking artifacts.

And another example here:

You can see that for example the x265 is much smaller and much better quality on pc, yet on Infuse on apple TV the x264 version looks actually better. So right now I think this is at least an issue with either the way Infuse or Apple TV decodes the media.

For the way Infuse decodes this frame for the x265 stream please look at the first post.

This is still on our radar to investigate.

The sample you sent in was a 10-bit BT.709 (SDR file). Are all your HEVC files encoded this way?

Most of the HEVC media I sampled from my library is 10-bit, either SDR or HDR. They are either BT 709, 2020 or unspecified.

I have also done one more test: I used Infuse on my phone to access the same files (the 265 and 264 encodes) and they exhibit the same behavior: the 264 looks better. So I think that should lend more weight to the idea that the apple TV or the apple TV settings are not something that come into the equation -unless there is large portion of hardware / code they both use and Infuse leverages.

Hi, James!
I was wondering if you were able to reproduce this or if you need more samples / information?
Thank you!

Hi, James! Sorry to be so insistent, but my window to return the ATV and decide on the subscription is closing. Please let me know if I can offer any more information, test things etc

This is still being looked into, and we hope to have more news soon. Thx.

Thank you, James!
If it helps I also found some time to test with Plex and this file plays with almost no artefacts -enough to not be noticeable from viewing distance anyway.

We have tracked down what was causing this, and will have a fix available in the next update.

Thanks for the report! :pray:


This sounds good. I’ll try to evaluate it once the new version comes out -I still have a couple more days return window for the ATV. I had to cancel my trial for Infuse in the meantime but I hope I will still be able to evaluate without it.
Thanks & looking forward to it!

This has been resolved in today’s 7.5.5 update. :slightly_smiling_face:

Thanks for the report!

Thank you, James. I still have the ATV but the Infuse trial expired. I hope I can still test this with the files that were problematic.
Can you perhaps share a bit of light on why it was happening?