Bad subtitles behaviour Media Player

I installed ATV black 1.1.1 so the newest version and all my video’s play great. But the the thing that irritates me is the subtitle part. The thing is that the subtitles a disappear to fast and also sometimes it starts a little but earlier than it must me,not much, but it is noticeable. I tested it with several movies on my Mac and my Dvico Mediaplayer and the subtitles play there correct; correct length and start-time. 

Hope this will be fixed in a future release

Could you open a support ticket and send in a sample file you’re having trouble with?

I have trouble with all video’s. Play only .mkv. But that is not the thing i guess. Watching a movie with subtitles is doable with the Firecore player, but you notice the subtitles are dissapear faster then is ment to be. I record tomorrow a video and then you can see the difference clearly. Situation 1: playing on my Mac. Situation 2: playing with firecore mp. Make the video splitscreen so you can see the difference very good.

Think that is better then making a sample and show it. Also i need then sync the subtitle again and it is not one particular moviefile.

Here is the video i made and you can clearly see the difference with timings.


Thanks for the well thought out demo.

Are these embedded or external subtitles?

If there’s any way you can provide a sample file you’re having trouble it would help in tracking down what’s going on.

External .srt file. Will try later a sample file. Thing is i also need to sync the external .srt for a sample.

Hope i can find a good program to make a sample. Have a Mac so that’s make it also more difficult to find a program :) .

But i have it with every file. So you can check it also out with your own video(mkv) files with external .srt. And compare it on for example XBMC on the ATV2.

Sure, if you can send in the .srt file that should be sufficient.

Think we don’t understand each other correct. I guess you have also HD .mkv movies in your collection. And you have maybe also non-English(guess you are an American) movies where you need subtitles for. So that is than you can test .srt with your own collection and you see clearly the difference - So not,give me some titles and i will search for (dutch) .srt subtitles file. You can do it also yourself on the following site, but it is dutch;

I used the following scene release in the video(maybe that helps): Ice.Age.A.Mammoth.Christmas.2011.720p.BluRay.x264-FRWL(1.26GB). If you want i can also send it to you(with .srt) with But I assume you see very good the difference in my video; xbmc start and ends correct and reads better( you don’t have to read very quick. Hard for my girlfriend to follow a movie.) 

Actually if you’re able to send in a problematic SRT file we can compare the behavior in XBMC and MP. We won’t need the corresponding movie file, just the srt file.

Once we’re able to replicate the issue we can most likely find a way to solve it.

Yes i hope it also.This topic is never ment to be a bitchingtopic, but to solve the problems. I’ll zip some .srt files for you. Link under this msg. But i have it with all the mkv files and .srt subtitles. I think it is not about the .srt’ then. Think the encoding(or how you call it) of subtitles is not correct.



Thanks. We’ll take a look.

Have you tried adjusting the encoding type? This can be done through the Playback Menu as described here.

I have exactly the same issue ! I opened a ticket yesterday : 

Nice! Not for you of cource, but that im not the ony one. Think that there are more, but not complaining and take it what it is.

Shall try to set an other encoding setting. But i think that is not the prob, because it is for that it displays characters right. But try it asap anyways.

Edit: change the encodesettings of the subs, and no difference.

And James, already know what the problem is?

@James: The new release(1.2) does they fix the subtitle problem? So yes, then i know i must told my dad to buy it also.

Just tested and unfortunately don’t fix it. Wait for a next release and it will be fixed.

Still working on this one.

Stay tuned.

Nice to read you try to fix it… great, and hope you can solve it. Just watch today again a movie with Firecore instead of XBMC(because in XBMC i get too much buffers) and i must admit it was again really enjoying with the subtitle behavior

Maybe you can also try to position subtitles in black bars(or little in the movie and second line in black) if you have a 2:35 movie. In XBMC they have the same position even if the movie is 1.85:1 or 2.35:1 and i like that very much. 



And does version 1.3 fix the subtitle problem?

Nope, it does not. Not for me at least.


How is the progress on this? Have you been able to re-create this your ‘lab’? Or is this a problem only experienced by a couple of users? :slight_smile: