Background app refresh not working

In the last several updates Infuse no longer makes use of the background app refresh that Apple added. On multiple ATVs and iPhone none will update in the background anymore. The devices used to update on a nightly basis.

All of my devices have background app refresh enabled and Infuse is the only app selected to use it.

It seems to take quite a bit longer to complete the server scans and icloud syncs since it no longer takes advantage of the background app refresh option.

Could we get this back?


Or perhaps it is a new OS change? But yes my mac hadn’t done an iCloud sync since Dec 6th when I opened it yesterday (I don’t use infuse on my Mac too often :wink:)

1 Like

Well Infuse still shows in the ATV settings as able to use the background refresh so if something changed in the OS then Infuse should be able to make the changes to get it to work with the OS feature again.

I have two ATVs that I let go for a couple of weeks and neither updated at all.

When it was working it’d be just a quick scan on launch and it’d be all caught up with the iCloud data and new files added.

1 Like

Yea the background app refresh is something I’ve been hoping would do the trick for me as well.

I have one ATV box that gets used on the weekends, the library updates on it are always slow when it comes to using it. I’ve been leaving it powered on for about a month now hoping it would catch up by the time the weekend comes around but it doesn’t seem to.

1 Like

I’ve also been noticing this.

1 Like

I’m wondering if something got broken in the recent changes Infuse had for iCloud sync and it may take a bit of rummaging around in the code to figure out what got trashed.

I really did like it when Infuse would launch and show everything updated with a last update time of the middle of the night.

Kinda like the elves were working overtime. :smiley:

1 Like

Agree 100%. And kudos for breaking out the elves reference this morning :grin::christmas_tree:.

Merry day to all who celebrate; Fine day to all.

Me, I’m just hoping my local Asian buffet will be open for dinner this evening.

Didn’t I just see that on one of the syndicated “The Goldbergs” episodes? LOL Enjoy and have an extra helping for me.

1 Like

I believe I am experiencing the same issue. Sync is never happening in the background on any of my devices (with plex).

I use the App for Apple TV, iPad, iPhone and Mac.

Agree. Same issue here, I have two latest ATV and both take long time to sync and sometimes don’t sync. I even fresh installed on both but same behavior.

I came here to see if someone else noticed it as well.

I don’t think this ever worked on either of my ATV’s. Every time I launch, I always have to wait 30-120 seconds for it to refresh content and Now Playing/Up Next from Plex.

This might just be the spin-up time of your media server. We’re talking about things that formerly synced to iTunes (from our various devices) overnight (or when otherwise idle) no longer doing so. That the only way to get each device to sync now is to force it to do so on the library settings page.

… Which is frustrating because if you sync devices in the wrong order, older watched statuses can replace newer ones, and other fun little glitches.

I wiped my (moderately large database — almost 3,500 movies, almost 13,000 episodes) and reimported. Import stopped when in background on both devices. Had to turn off picture without turning off TV and Apple TV to complete.

Poster art (and even genre / decade art) also fails to populate in the background. I basically have to view every folder to force-get the art to populate. And often times it doesn’t stick. Several days later I still open Infuse to generic gray thumbnails and generic fanart button backgrounds on the Home Screen. :frowning:

Anything new on this issue? Doesn’t seems like it syncs in the background for me either.

I’ve had my apple tv couple of weeks as I understand the infuse app should go check for new content even if the infuse app isn’t open?

This has never worked for me. Each time I open the app it’s start checking for new content and then fails.

Has something happend recently with the background sync?

I’ve ethernet and 1gib connection to my apple tv 4k

I moved your post to a currently running thread discussing this problem. :wink:

@james Just to add some more info, tonight I launched Infuse on an ATV4K that I have intentionally left idle for over 3 weeks. ATV powered in sleep mode and Infuse in the background with no other use. After launching Infuse and going directly to the library settings page it showed last sync over 3 weeks ago.

As a side note, it took about 45 minutes for it to finally complete a sync to current values.

Something has gone south with the background app refresh. Verified that background app refresh is set to on and the only App allowed is Infuse so it’s definitely broke.


I too am noticing extremeley slow content updates (ie like your 45 + mins) vs several months ago.


I am with our mod on this topic.
+1 it should have background app refresh.


I positively remember there was a time when the iCloud sync updated changed thumbnail pictures and metadata. Since a while (sorry I don’t know exactly since when) this very useful feature doesn’t work for me any more. I hope it’s just a bug in Infuse and be fixed soon?

1 Like