Back up didn't work for me

Before upgrading to version 5.2, I installed ATVFlash 2.2 on 5.02 and made a full back up which ended up successfully. I didn’t test or check the back up, because it ended up successfully.

I then upgraded and jailbroke the Atv and installed Atv Flash 2.2 and all available software, then I tried to do a restore from back up, only to find out that the latest back up had 0 (zero) bites. 

Luckily for me I had a back up from november 2012 and used that as a starting point, I had to reset the watched history and add all my library again and mark as watched all watched movies from November.

My mistake was that I didn’t check the back up and that cost me about 2 hours of setting up.

Sorry for the trouble. Did you get a visual confirmation the backup was complete, or did the Apple TV just go back to the main menu?

Sometimes the Full backups can get so large that the Apple TV won’t be able to handle the file size, and will simply crash.

The ATV didn’t go to the main menu. In Maintenance, I got the message that the back up was successful, but when I tried to restore, the next day, it was 0 bites.