AVI's are choppy

For some reason, whenever I try to watch feature films they are choppy and I can’t get past the first couple minutes before the whole thing hangs.

Short, lower quality videos don’t have this problem.

Anyone know what I’m doing wrong? I have installed the latest version of ATV and downloaded the latest mplayer files.

AVI files are best played in Quicktime. This is the default player in the Media and Files plugins, or you can change the playback mode in the DVD > Settings menu to Quicktime or mixed.

I changed the playback mode in NitoTv>Settings to Quicktime. (I don’t have a “DVD” menu)

I am still having the same problem.