AVI files not recognized...?

I just installed the latest ATV flash. I then moved some AVI files I created using my digital camera to the ATV movies directory via FTP.
When I got to “Files” or through Nito TV and click on any of the files…they will not play. I get “The Selected Video Could Not Be Played…the format could not be recognized” message. These are standard .avi files. Apple TV is fully updated to 2.4 and aTV flash is 3.63.
I must say…so far i am pretty bummed. This was one of the basic promises of paying for this thing…the ability to play standard files without having to encode to apple recognized format. Sure hope I can get this to work. thx.

Hi there!
Perian is installed, right?
I don´t know what you mean by standard avi (meaning there is a standard for the container format but that says nothing or very little about what´s in it). Maybe the resolution is not supported or - my guess - it´s the wrong codec. http://en.wikipedia.org/wiki/Container_format_(digital)

I am facing the same problem I can not run the trailer videos from Apple or Jaman I have not tested the rest after upgrading to 3.6.3…i am getting

The Selected video could not be played

The format was not recognized

also when left for a while the system becomes slow and it need to be restarted

any help pls…???

You may try toggling the ‘Apple H.264’ option in the Maintenance > Settings menu. This will toggle H.264 video playback between the Apple or Perian component. Depending on the video file, one component may be better than the other.


I bougt aTV Flash to have access to about a Terabyte of old home movie that were on VHS tapes and I had converted to AVIs. 

I finally got NitoTV networked to my Mac today and it is able to see and play mp4 files.

While Nito can network to the AVIs, when I try to play one it says "The selected file could not be played the format was not recognized."Perian is installed. I tried switching the Apple H.264 option in Maintenance>Settings as suggested above but got the same result. 

Any suggestions would be welcome.