AVI Error with Media Player

Can media player play .avi files? I’ve got all kinds of formats that play using media player, MKV, MP4 however my avi files gives me an error. Am i missing something, or is this an extension that isn’t currently supported?

Thanks in advance,

Dale

I play .avi files all the time, so there is no inherent problem. However the .avi type is just a container (rather like .zip), so it can contain video that uses an unsupported format.

Can you tell us more about the codecs used by the files in question? More details about the actual error reported might help as well.

It’s just that every .avi file i try to play, I get a Playback error message, saying an error occurred loading this content. I’ve tried multiple avi files from different sources.

I’m currently on 4.4.4 jailbroken, running Media play 1.5-154214. All other formats i’ve tried seem to play fine except .avi

The codecs i’m trying to open seem to be MPEG-4 Video (DX50) and MPEG Audio Layer 1/2/3 (mga) -  I would think this one would work…

Another Code is Motion JPEG Video (MJPV) and PCM S16LE (araw)

 

Thanks,

What type of device are you streaming from?

Using AFP, NFS or SMB?

Streaming from my Macbook Pro which Media Player set up as AFP, i’m not sure how to change this designation if even possible? Media Player found my Mac when i added it as a share. All other formats work, just not .avi, which is the bulk of my library at the moment.

 

thanks,

So, i uninstalled media player, then installed it again. The first .avi i tried worked, however lots of buffering. I then exited out, and tried another…i got the same playback error message again. I tried to play the .avi that worked previously, however it now errors again. There must be something wrong with the unit, however i don’t want to jailbreak again as i want to remain on 4.4.4 until an untethered version comes out. Grrrrr.

Thanks again,

Yeah, I have the same issue with the DX50 codec - it doesn’t seem to be supported by hardware-decoding :frowning: