Automatic Library syncing option

Hi

every time I run Infuse on Apple TV I have to go to Settings > Library and manual search for changes. In other words, if I add something to Plex library, it’s not automatically syncing to Insuse untll I force for changes.

Are you preparing these feature in future release or its already there and I am missing something?

Thanks :slight_smile:

Library updates are actually automatic, and will take place whenever the app is opened. It will also happen periodically on its own if you leave the app open.

Also, you can manually trigger an update by tapping the ‘Last Update’ texts in the Library menu, which may be quicker than going into Settings. :slight_smile:

These automatic updates are not happening for me. At least not soon (I’ve waited minutes; not sure the max…). I too (as others have mentioned) generally have to go to Settings>Library and manually start them, then my library is quickly (<60 secs) updated. For what it’s worth, my source is a webdav folder.

Exactly, but it seems it happening only on tvOS, iOS is fine.

Are your files on a NAS or on a computer attached to the network? If computer, are the files on an external drive?

Personally I’m using Put.io/webdav. But it doesn’t seem like my sources should come into play on whether my sources are refreshed — seems a little downstream.

My files are on Synology NAS running 24/7. When I add new content on NAS its immediatwly accesible via Plex app on Apple TV, but not in Infuse until I manualy sync them via Settings.

Just trying to get an idea of what you (and some of the others with similar situations) are using. When you open Infuse and go to the Library, does it say “pending” below “Last Update:”?

I have the same issue from nas. Only started with the latest update.

No, there is just a date of last (forced) update and it won’t change with time until I hit the “Search for changes” button.

Okay so there is no progress indicators below the last update time, what happens if while you are in the library and scroll down through movies, tv shows, other, and search to highlight the last update bar and then click on it?

Note, this is while in the favorite “Library” not in the “Settings” > “Library”

I think the confusion is that the background refresh only seems to happen if nothing is playing. If you’re watching stuff (which we’re want to do while using Infuse) the background refresh doesn’t happen, so you have to force the refresh. Infuse really should update in the background while videos are playing, the bandwidth for library updates should be minimal.

That’s the reason I specified when they open infuse to see if it shows pending or not.

It seems its now working fine. I have added TV series to NAS and it finally showed up at Infuse. It had to be some sort of glitch before :slight_smile:

Great! Good to hear. :wink:

Thanks for letting us know.

Still doesn’t happen for me. I have to manually start a refresh or it’s minutes before new content pops up. Obviously on fresh app start it happens semi-immediately, but I can’t be force quitting the app every time I leave (actually, I don’t even want to be leaving the app — I’d prefer if a refresh kicked off every time I navigated to the main Infuse page/dashboard).

I totally agree. It might take longer but i’m Tired of my wife complaining the the show I said was there not showing. Then explaining that she needs to keep stepping back and try again. Give us an option to rescan when clicking on a share!

You may want to start a thread in the “Suggestions” forum to get more eyes on your request.

Edited to add: There is already a thread running in suggestions that sounds like it’s what you’re talking about.

Hi! This issue/bug is now over a year old? Has it been resolved/fixed?

im testing right now Infuse if it is suitable for my needs. I have included a WEBDAV(HTTPS) as file source in infuse. i expected that Infuse is (instantly or at least periodically) scanning my file source for new entries/files.

But if i open Infuse (on iOS, iPhone XR latest version), my library is not updating with my new movies/tv shows. Left the App open for at least 20 minutes. i need to go to settings and trigger the manual library scan button.

In my opinion such a basic feature like automatic library scan is a must have. On always Powered devices like an Apple TV i expect this to happen in the background.

Can the Mods, developers give here information when they plan to fix this issue? I hesitant to buy premium when such a crucial error is still not been fixed/included

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.