Audio sync issues with Apple TV 4K + Match Frame Rate (24p)

Hi!

New Pro user here, loving the app, but incredibly frustrated with audio (lip) sync issues when playing 24p content on my Apple TV 4K (1st Gen) with “Match Frame Rate” enabled (as it should be).

This problem seems to also affect other players (Plex is even worse), but it’s noticeable enough in Infuse to make the watching experience unnerving to say the least.

My Apple TV is connected (through HDMI) to a Denon receiver, which then forwards the video signal to either my TV or projector (both show the same issue). Audio is output to stereo speakers directly connected to the receiver (so no wireless audio anywhere).

If I switch off “Match Frame Rate” everything’s perfect in terms of lip sync, but video playback is terrible (i.e. wrong frame rate). Switching it on, causes the audio to lag by about 100-140ms. Content is essentially 1080p SDR MKVs hosted on my Plex Server (home network, cabled).

I just need to know: is this an Apple TV issue? If so, could you ever do something to compensate the lag? If it’s an Infuse issue, when do you expect to fix it? If it’s neither, what else could be causing this problem? I’ve seen many similar complaints over the last couple of years, but no-one has ever reached a definite conclusion. And, for the record, switching off “Match Frame Rate” is NOT a solution, cause it makes the video stutter and look awful.

Thanks in advance!

Is the audio in front or behind the video? Did you try adjusting the sync on your Denon? What happens if you plug Apple TV directly into the tv? Is it exactly the same with tv and projector or the same?

I personally have no issues going through my denon to my tv so my guess is there is something in the path causing it, even if you are only changing a setting on the Apple TV. Hdmi handshakes can sometimes mess things up.

Thanks for the quick reply.

The video lags behind the audio, by about 100-something ms. I tried adjusting the audio delay on my Denon, and I got it pretty close to being acceptable, but this is obviously not ideal as I’d have to change it back every time I use a different source (like my Blu-ray player). TV and projector show the exact same perceptible audio delay.

I have not tried to connect the Apple TV directly to the TV, but I’ll do it now and report back.

You may want to check, my Denon has stored settings for each input so I can have a delay on the ATV input but none on the blu-ray if I want.

Hm, yes, that may actually be the case. Thanks, I’ll have to check this.

I have some updates, though:

  • Connected the Apple TV directly to the TV → no delay;
  • Connected it back through the receiver → delay is back.

Then, whilst still connected through the receiver, I changed the “Audio Format” settings on the Apple TV from its “Auto” default to: Change Format → ON ; Format → Dolby Digital 5.1.
The delay (mostly) went away (i.e. it’s barely perceptible).

So what do you figure is going on here? Remember that this only occurs with 24p playback, and it’s exclusive to the Apple TV (my Blu-ray player is flawless in 24p through the same receiver). Also, HDMI cables are identical for both sources (tried switching, no difference), and all video processing is turned off in the receiver.

I’m with @munpip214 , After dealing with HDMI demons a few times and running out of chickens to sacrifice on the ATV I changed a few HDMI cables and resolved the other issues I was having.

Maybe if you have a couple of new HDMI cables you may want to try changing the current ones out just as a test.

This thread on AV forums talked a bit about this too.

I’ve just made an edit to my last reply, stating precisely that I’ve tried switching HDMI cables (between the BD Player and ATV) and it made no difference. They are identical, though, so maybe I should try a different brand and see if it helps.

Either way, the “Audio Format” setting seems to have mostly eradicated the problem, so I’m gonna try and live with it for a while.

If anyone else had a similar issue, please let me know what you’ve done to try and sort it out.

Cheers!

That makes me think that there is something happening with your receiver or something down the line. Did you try turning everything off and back on again? If you have CEC enable try disabling and see too.

Check to see if the receiver and your tv have a lip sync feature. If they do disable it on both devices. Additionally if the receiver has any sort of processing video feature turn that off. I had an older denon receiver and it had a feature that allowed it to inject menus in with the video feed (a menu overlay) and once I disabled this feature it cleared up my sync issues.

I also have a Denon receiver. 2 years back I made a choice between Denon and NAD. I choose Denon.
BUT, I am not so happy with the Denon, switching from ATV to TV or Bluray or visa versa etc. takes very very long, sometimes over 5 seconds. And sometimes my TV (samsung UHD) turns of because it thinks there is no signal. It is definitely a Denon issue.

About the lag and lip sync. Denon has a built in Conversion for video etc. You might wanna turn that off so it just gives the same signal to your TV as it comes from the ATV. (as JarvisMeier) says.

Maybe that helps.

PS. My Denon is now 2 years old and I never had a firmware update. (weird)

I don’t think this is specific to denon. It is because devices like Apple TV and Blu-ray players don’t support fast frame rate switching over hdmi 2.1.
https://www.hdmi.org/spec21sub/quickmediaswitching

I read the article… but I do not understand. I have the best HDMI cables I could get…

How can I solve this issue then? I would like to have it change just like switching tv channels.

I have this issue when using the Denon. Like from the remote control I push the button mediaplayer when I want to switch from TV to ATV… then it takes annoyingly long before ATV comes up and visa versa.

PS. do they refer to the man with a hammer inside the Denon when using the word “BONKS”?

Unfortunately it is up to sources to support the format. So Apple TV would have to update to enable that. You might be able to workaround it by fixing all frame rates to the same value 24 or 60 and disabling frame rate matching.

Thanks everyone for your feedback.

In regards to video processing on the receiver, as I stated before, it’s all turned OFF. The receiver’s LipSync feature is ON (that’s the default), and switching it OFF makes the problem worse (not better).

I haven’t tried switching to a different (brand) HDMI cable, but enabling the “Change Format” audio setting on the Apple TV (to Dolby Digital 5.1) seems to have effectively solved the problem. Even Plex’s own video player behaves fine! So I may just leave it at that for now.

Of course, this won’t be a solution for those with audio requirements that include Atmos, but luckily that’s not my case. I still have no idea what’s going on here (it seems like an issue decoding audio in a certain format), nor if the fault lies with the Apple TV or the receiver.

I actually tried this (i.e. setting the Apple TV’s global video frame rate to 24p), and it didn’t really help. The problem is definitely when playing 24p video, not the fact that we’re forcing it to switch frame rate beforehand.