Audio out of sync

Guys, it’s “better” but NOT fixed. Sound is still out of sync and it “seems” the longer into the movie you get the worse it is off.

Come on, this is painful.

I agree. It’s better but still not “spatial” enough compared to Plex

Not about “spatial”, at this point I could care less about Dolby Atmos. The issue is ridiculous audio / video dialogue sync issues. Movies are UNWATCHABLE because the audio coming out of the ATV4K + HomePods is NOT in sync with the dialogue being spoken. It is very distracting and we have no way to adjust.

I am not having this issue with other apps like NetFlix, AppleTV+, Amazon Prime Video or even YouTube which recently corrected the issue.

The changes in 6.6 were aimed at improving audio quality for HomePods, and it sounds like the issue you are seeing is a bit different.

We’re not seeing widespread reports of audio sync issues, but we’d like to look into this.

  1. What type of files are you playing (movies, TV shows, TV recordings, etc…)?
  2. Is this happening with all files?
  3. Are these audio sync issues present if you download one of these videos?

Same problem here with movies. Seems like it’s the “length” that taxes the app? No problem in 42min episodes of a series, but watching a movie is… well: unwatchable.

I finally gave up and found it on AppleTV+ and rented it.

Hello @james while not a sync issue, I have noticed that the current version of Infuse on TVOS continues to report surround sound data (multichannel PCM) to my receiver whenever I cease playing an MKV movie with DTS/Dolby 5.1, 7.1 etc. (stopped by pressing menu on the remote of course). Accordingly, when you’re back in the infuse UI menus after exiting the film, the receiver still thinks you are receiving a multichannel signal instead of a stereo signal (causing some distortion during menu surfing). This issue stops when you leave the infuse app and return to the tvOS Home Screen, where stereo output correctly resumes. Can you take a look and see if this needs addressing?

To make a longer story short, infuse in tvOS continues to report that its playing multichannel tracks even when playback of an mkv movie ceases and you’re back in the infuse library menus.

My Apple TV is plugged into an Arcam AVR30 receiver but the issue stems from the app not the AVR.

@james,
it is much “better” however, the sync is still not 100% all the time. Sometimes it’s better than other times with various source material, other times you can see the audio and video un-sync as the source material plays. Why can’t there be some type of manual adjustment built in?

6.6.3 (3508) updated and audio syncing issues are STILL there! This is getting seriously frustrating and does not make me want to continue to move forward with Infuse Pro.

I’m using a Synology NAS streaming to ATV 4K via Ethernet CAT 6 and audio source are a pair of HomePods in stereo pair. It is “better” than it was originally but after months the issue remains unresolved.

I can understand the frustration but I didn’t see where you had answered the last group of questions James asked. When there are very few users having this problem it helps to get all the info possible to try and fix it but if it can’t be replicated then it’s nearly impossible to fix.

With the variety of videos in that link above testing those and seeing if they all result in the same or possibly different results may help narrow things down.

If you don’t see this issue with all videos it would help to know which ones do work. If it’s all videos then that may help too.

I have tried several times to download those and slow as molasses. I’m on a 600Mbps d/l connection and these things sit for hours and never d/l.

Try this Dropbox link.

Well, yes that did work.

But are you making a joke or something?
The issue is audio sync and the cartoon you sent has NO spoken dialogue! On top of that is low-res.

What gives?

Sorry, there is audio so it should be possible to see if things are in sync…but I guess not as great as a dialogue-heavy video.

Do you have the Match Content options enabled on your Apple TV?

Does turning these on/off change anything with regard to audio sync in your setup?

I’m not seeing audio sync issues (could be that guy’s receiver or sound bar). However, I am seeing that latest versions of infuse continue to report MultiChannel audio, when it should be stereo, after exiting playback of an MKV file with multichannel audio (ie Atmos, DTS-HD, and the like).

So, much for “reading comprehension”.

There is NO sound at or receiver. The issue manifest itself streaming from Apple TV 4K to a set of paired HomePods set up as a stereo pair and wirelessly calibrated on ATV4K.

So there is your issue. Not infuse. As i hinted. I didn’t care about your setup. I brought up an actual issues. Yours is not an issue with the app.

James,

Turning off “Match Frame Rate” does improve it but it’s still slightly off. I acknowledge that it’s has improved it seems a lot of people are either satisfied or not sophisticated enough to discern the audio is not 100% synced. It is an issue with Infuse although Plex has also been going through same since Apple released the HomePod stereo pairing firmware.

Thanks for confirming that.

I wonder if this has something to do with the actual TV’s settings, and perhaps some framerate motion processing it’s doing.

Can you try browsing through the TV’s settings to see if there are any features like this you can disable?

All digital nonsense has been turned off on TV, It’s a Samsung UN65JS8500. All other streaming content is fine. I did have issues with all right as did many online right after Apple released the HomePod stereo pair firmware. This issue is ONLY with the HomePods as audio source.

Hi, im getting a very small sync issue with my homepods. Ive checked it by playing the same video through plex and the audio is in sync on plex. When i play it in infuse its out of sync.

Format is 1080p SDR 24 (23.976) Audio is EAC5.1

Any help is much appreciated