Audio noise when playing mkv files

Hi,

I just purchased a new aTV 2 and installed the good firecore things. But when trying to stream the first two mkv files from my Mac Mini’s external drive I can either not hear any sound (AC3 and DTS disabled) or just noise (AC3 or DTS or both enabled). I am not using the optical audio, just HDMI to my TV.

Anyone has an idea? Since I am new to this matter I may have missed some settings.

thx,

Chris

Update: The third mkv file now plays without audio problems.

When I look at the metadata of the files displayed by the media player, one file that doesn’t play has audio “DCA (DTS Coherent Acoustics)” and the other one “ATSC A/52A (AC-3)”. Are those types not supported by the media player? Or am I still missing some settings?

 

thx,

Chris

Hi Chris,

Try setting the audio output on the regular aTV2 setting screen to 16-bit. it should work.

let me know if this works for you.

Hi,

Thank you for your fast reply. Unfortunately it doesn’t work. When I checked the settings it was already set to 16 bit. I changed it to Auto, tried playing the movie again, and when returning to the settings pane it was set to 16 bit again. Somehow this is modified by the aTV. 

Maybe you have another idea?

regards, Chris

how do you have your atv2 connected? It could be an issue with your receiver not recognizing the signal or the MKV file. I have all my ISO converted to MKV and they work fine.

can you try an ISO file and see if they work?

Let’s try to isolate the problem from the file and see if it is an issue with the receiver (if you are using one) I don’t know.

I have the aTV connected with an HDMI cable to my TV. That’s it. No A/V receiver in between. I’ve also tried to play with the HDMI Audio settings on my TV but I only can choose between Auto, Analog and Digital.

I don’t have any ISO but I will create one of one of my DVDs and then try to play it.

Update: I just tried to play some more mkv’s and one where its audio metadata says “DCA (DTS Coherent Acoustics)” is working. Great so far. That means that it obviously is a problem of the other files. Which is bad on the other hand since I need to get them from somewhere now or convert their audio tracks… if this is even possible.

 

Experiencing the exact same issue here… DTS or AC3 audio in .mkv files produce only a hissing static. Using HDMI directly from ATV Black to TV. All others with .mp3 audio work great.

I spend the day doing testing and I see the same problem. It seems to be a software problem. I will go ahead a report an “official” trouble ticket to see what they have to say.

I’ll will keep you posted.

I also have the same problem, watching this space for an update!

If you’re AppleTV is connected directly to a TV (no AV receiver) you will want to disable both the AC3 and DTS options in Media --> Settings, and setting the AppleTV’s audio output to Auto in the Settings --> Audio & Video menu.

The AC3 and DTS options are only used when the AppleTV is connected to an AC3 and/or DTS compatible AV receiver.

James, you were totally right! Big thanks for pointing out the fix! Keep up the great work!

Great!

In My case the AppleTV is connected to a receiver (KRELL S-1200U). As described before, when AC3 is enabled no sound is produced.

Tonight I did the following test.

Movie: Artificial Intelligence

Media: DVD, ISO format

This movie has both, AC3 and DTS tracks. When the AC3 audio track is selected no sound is produced, when DTS audio track is selected sound is produced properly and AV Receiver goes into DTS mode.

This test was performed with AC3 and DTS option enabled. If AC3 option is disabled sound is produced in Stereo mode.

Audio Setting on AppleTV was tested in Auto and 16-bit setting. This setting didn’t make any difference.

DTS setting did make any difference during this test.

 

@james: I tried that already but then I don’t have sound at all. 

Hi James,

I just plugged the AppleTV directly to my TV using HDMI and used the setting you recommended, but it produces the same results (no sound).

Let us know if you have any other ideas.

This morning I sent the Support Report from the AppleTV is case you may want to see.

Thank you,

Thanks James that trick worked, I have sound. Thanks for the quick response.

My aTV 2 is connected to my TV with HDMI and to an AC3/DTS receiver with optical.
Sometimes I want to listen to the sound through the TV only (late at night) and sometimes I want the full monty.
I foresee a lot of configuration switching going on :-S

ignore

Same problem with .mkv files here. They play nicely with VLC on my Mac, but with FireCrore ATV MediaPlayer the sound is not playing correctly. I have disabled AC3 and DTS, and set the audio autput to Auto. The ATV is connected to my brand new Panasonic TX with HDMI cable. Other files plays without problem.

I have also sent a support request 23h ago and waiting for a response. 

Same problems here.  With AC3 and DTS disabled in Media Player and Dolby disabled in the ATV settings menu (what should be the proper settings), I get garbled, slowed down, totally unusable audio.  However, with AC3 & DTS enabled in Media Player, I get a momentary static sound when I first hit ‘play’ but otherwise the audio is fine.  Also just connected straight to TV with HDMI.  Problem existed both before and since updating to RC1.