Audio gets out of sync when video sped up

I’ve consistnetly had issues whenever I watch videos sped up where the audio gets out of sync, normally after pausing and resuming the video. The quickest fix I’ve found is skipping back using the left direction button on my apple tv and that normally resync things, but it is very frustrating.

My setup is:

Apple TV 4k (latest) -HDMI-> Projector
-AIRPLAY-> 2x Homepod

This setup works great with every other video player/streaming service, but not Infuse.

2 Likes

Welcome to the forum!

What version number of Infuse are you using?

7.4.2

Here are two example clips:

Movie played at 1x speed. Playing and pausing the video audio stays in sync and there are no issue:

Same movie played at 1.5x speed. Pausing and resuming the audio is now out of sync (on occasion the audio doesnt come back at all). If a rewind 10 seconds once or twice it will usually get the video back in sync (as I demo in the clip):
https://vimeo.com/732599887

To help further troubleshoot, I switched the audio output to my projectors build in speakers. In that case, pausing/playing or skipping around does not result in the audio getting out of sync.

So it does appear that this is an issue with Infuse used in conjunction with Apple’s Homepod/Apple TV home theater audio feature.

Please let me know if I can help with any other troubleshooting or investigation, this would unfortunately be dealbreaker for me in using Infuse. I am hoping it isn’t too tough to fix, I don’t have similar issues in any other apps at the moment.

it is also happening to me that the audio is ahead of the video, I have tried different files and it is still happening.

I think it’s due to the latest tv os 16 update.

please keep an eye on it

PD: In my case it is with normal reproduction

I’m also having issues with the audio gradually becoming out of sync when using increased playback speed. It seems to be a problem with every video file I play. Pausing the playback will temporarily reset the audio sync, but I need to do this repeatedly throughout a movie or TV show.

I’m on an Apple TV 4K running iOS 15.6. I’m connected to a television, not a projector. I’m a newer customer of only a few months and this has been an issue for the entire time I’ve used Infuse.

I am still experiencing this problem, even after upgrading to tvos 16. Does anyone at Firecore even monitor this forum? Is there a better way to get a response on this issue? This is easily reproducible and has been an ongoing issue for over a year (at least) at this point

You could try the in-app support option. Go into settings on whatever device you’re using, use the “email us” option, and it’ll connect you to support and provides a convenient way to send them some diagnostic info as well. I just tried this myself and I got a response within a day or two. I would think your input and data would be very helpful to them in fixing this issue.

We have a number of improvements coming for variable speed in the 7.4.6 update.

If anyone would like to test these early, please let me know and I can send over an invite for TestFlight.

1 Like

That’s wonderful news! Thank you very much for looking into this. I’m going to hold out for the official release but I wanted to say thanks and that I appreciate your work. :slightly_smiling_face:

I have the same issue recently.

This should be resolved in today’s 7.4.6 update. :slight_smile:

Thanks for your patience.

2 Likes

So far it’s been working perfectly for me after the update. Thank you so much for your work on this. :+1:

3 Likes

Yes, for me no problems anymore after the update. Thanks as always!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.