Audio drop

When playing files (720p dolby digital) the audio now and then stops. Pressing pause and resuming makes it play again. Appletv 4k is connected directly to an LG C7 which in turn sends audio to an NAD T748. Haven’t discovered a pattern yet. Hoping to solve these issues or I’ll have to return the appletv. Diagnose code 1C9GE

Just for info, I had similar issues with audio going through a Philips Android TV to a Denon Soundbar via optical audio.
It turns out the issue cama with the TV’s Android 7 update. (painfully) Downgrading the TV to an Android 6 firmware solved it.

I am pretty sure the LG C7’s software is more reliable than the terrible software of my Philips TV, but you might want to make sure that it’s up-to-date. As well as the NAD’s. As well as see if there are any particular sound settings.
And does the audio also have issues when using the C7’s internal speakers?

Nor Apple TV nor Infuse should have issues with Dolby Digital audio. There is an Infuse guide about audio settings here: Audio Options (tvOS) – Firecore

It is also possible that Infuse has issues with the particular audio format of your file, or the way it is muxed, which would probably be an Infuse bug. Could you send a sample or give more info about the files you are palying?

:slight_smile:

Just regular dd5.1. TV media player works fine. Infuse drops out randomly. This morning dd5.1 only gave loud static noise. Files were 720p dd5.1. Aac stereo seems fine. Will have to check when I get home from my client.

*edit all equipment is up to date
Also tried Netflix on appletv and that has no issues with dd5.1.

Does the issue persist if you connect the Apple TV directly to the NAD?

You can also try adjusting a few of the audio output options in Infuse/tvOS to see if that helps things work better when going through your TV. More info on these can be found here. Audio Options (tvOS) – Firecore

The NAD is hdmi 1.4. So I cannot connect directly to the NAD.

I too am experiencing Audio dropout issues on Apple TV 4K. Dropouts appear to occur randomly and can last for 1-2 seconds. The picture is not impacted. I’m unable to determine if the dropouts relate to high volume or otherwise.

The Apple TV 4K is connected to a Sony Amp, and from there to a Sony TV (not 4K).

The “fault” I believe occurred out of the Box with the Apple TV 4K (I physically replaced the previous generation with the 4K one).
I also believe that the fault was presenting itself in Netflix and Infuse (and maybe LightBox - a local Application for New Zealand). - This leads me to believe it is a software/hardware fault with Apple TV …so to be clear I’m not blaming Infuse. I’m raising it here in case someone else has had this issue and knows how to resolve it.

I have replaced the HDMI leads, and I’ve turned off HDMI control on the connected devices. Of course this has not resolved the issue.
Also I am on the latest beta for Apple TV - the fault continues.

Any advice and/or guidance appreciated.

  • David

p.s. when the OS goes GA - I plan to turn of beta - and call Apple if it isn’t resolved. Especially if it’s a hardware fault.

Update:

I fixed my audio dropout issue!

While I have an Apple TV 4th Generation, I do not have a 4K Amp, or a 4K TV.
I went into the Video Settings on the Apple TV and alterer the output so that it was only720p - a substantial reduction on what was likely 4K output.

Seems obvious - BUT. And the Automatic setting probably was unable to detect stuff correctly.

Since doing this the Apple TV has performed flawlessly, along with Infuse and other applications.

  • David

p.s. I investigated calling Apple about this. However my Apple TV was out of Apples support window and there was no easy way to place a voice call. I was somewhat disappointed in that as the 4th Gen isn’t that old!