Audio delay needed when 24 fps content is playing

How come I need to delay the sound in my receiver by approx 130 ms when 24 fps content is playing?

When I play a 50 or 60 fps file, no delay is needed, the audio is in sync.

I remember years ago when using XBMC there was a similar phenomenon. Is there something inherent in 24fps playback that introduce this?

I have a setup like this:

ATV 4K → Yamaha A1080 Receiver → LG OLED

It might be because the Apple TV doesn’t support true 24p and plays everything back at 23.976

Do you have Match Content on in the ATV settings?

Yes Match Content is enabled. Disabling that probably fixes the issue, haven’t tested, but will. Having it disabled is not a proper fix though, I think Match content is crucial to watching 24 fps content.

Audio is set to Auto, so everything is decoded by Infuse/ATV and sent to the receiver as multichannel PCM.

Also, to be clear, the content Im playing is actually of 23.976 fps. I have no 24.000 content that I know also exists.

I don’t have the same issue with my setup and 24hz content. Apple TV 4K → Sony strdn1080 amp → LG OLED. It must be a way the amp is handling the audio. That being said an offset audio option would be nice for setups that need to be tweaked beyond the default.

Thats weird.

Found this previous post where James says its a quirk of the ATV when 24p and audio is set to Multichannle PCM.

Its irritating to always have to adjust the delay in the receiver depending in watching 24p or 50p content.

Can nothing really be done about this?