ATVFlash Installation Problem

Hello and happy new year !

I just purchased ATVFlash.

I seem to be experiencing problems with the installation.
I just bought an AppleTV 40 GB running software version 2.3

Could you please help me solve this problem.

Here is what I did :

Followed the instructions and installed the software(s) on a USB stick
Unpluged the Apple TV
Inserted the USB stick
Repluged the Apple TV
Got the ATVFlash logo
Got a lot of thext flying on the screen until it stopped at the following bit of text (I give you more of what was displayed on my screen in case it helps you solve my issues) :

(please note that the first one or two characters are not properly displayed on my TV… I’ll put ??? for those… sorry)

started : BusyBox v.1.9.1
?oot = patchstick – seraching for patchstick.sh
??? : unknown operand
?oot = auto/manual/patchstick failed – starting telnetd
?c (v.1.9.1) started
?ng discover
?ng discover
?ng discover
?ase, failing

   Link encap : Ethernet HWaddr 00:23:32:34:1A:4B
   UP BROADCAST MULTICAST MTU:1500 Metric:1
   RX packets:0 errors:0 dropped:0 overruns:0 frame:0
   TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
   collisions:0 txqueuelen:0
   RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
   Interrupt 18 Base address : 0x8000

And the screen stays like that… I left it hanging for 5-7 minutes. No change !
I have tried rebooting te Apple TV (with the USB stick) and I get the same exact text.
I then turned off the Apple TV, removed the USB stick and rebooted the Apple TV and everything is back to the regular Apple TV (no ATVFlash modules or plugins).

Your help would be greatly appreciated !

Thank you

Just to cover all the bases, you ran the aTV Flash application from the DMG and did not move it to the Desktop or the Applications folder, correct? Also you made sure the AppleTV 2.3 DMG was mounted and you saw the OSBOOT image mounted? If you did all that then either try another USB drive or make sure your AppleTV is hooked up to an Ethernet cable and not wireless. The patch does seem to have an issue when the AppleTV is not hooked up to an active Ethernet cable while running the patch. If none of the above works then let us know.

I received the same message. I upgraded the appletv to version 2.3 and I used a diffrent USB key (memorex roto 1GB - Wallmart). All works fine now

I’M having the same issue. I followed all the step tried 3 different usb drive. When i turn on the ATV it boot fine and connect to wireless fine. Just does not do it when i try to use the patch. Any idea’s I dont have a TV next to a CAT cable.

Are you using Windows or Mac to make the USB patch?

I am using the mac patch. I have tried with a Cat 5 cable. Found little tv. Still having the same issue. Even tried with out my apple extreme and right to the cable internet. No luck… O ya and it a 2 gig usb…

Edit:Ok found a old 512 flash drive poof it works. After 4 other didnt. And the other 2 work before… Well thanks again for the help.

i’m having the same problem. i tried with at least 5 different flash drives, including the 4gb sandisk cruzer which you show is confirmed working, and they are not even recognized by the apple tv – i don’t get the atvflash logo. the only drive that the apple tv will boot is a 512mb cruzer mini, but with that one i am having the problem described above… patchstick failed, etc.

i have atv flash 3.6.2 running from the dmg (didn’t copy it to applications) on mac os x 10.5.7. the apple tv dmg is mounted and i see the OSBOOT. the apple tv is plugged in thru ethernet and i have told it to check for updates – says it’s up to date.

after atv flash boots and errors out, i notice i can telnet to it and login with root / root. is there anything i can do via telnet?

we paid $50 for this

We’re sorry for the trouble. Please contact us directly at the link below and we can help troubleshoot your issue.
http://www.atvflash.com/contact.php