ATVFlash 3.4.3 with ATV 2.3 booting question

I bought ATVFlash in hopes for easier time getting the ATV improved… so far it’s not been very easy. I’ve used 4 different USB sticks, all of them work and write fine with the ATVFlash utility. I have the OSBoot (2Z694-5573-24.dmg) file. The experience i get when I boot the Apple TV is that I get a Apple Logo (different than the one, inverse in color/background) and then a few moments later the normal Apple TV logo. It boots fine, but all the additional menus aren’t there.

Any ideas on what I should be expecting or how to get past this? atvusb-creator worked fine, but the additional functionality in ATVFlash is what I’m after. Do I need to start from a Factory Reset?

If you have the USB Creator already installed, you should restore your AppleTV, I highly doubt the two patches play nicely together.

Before I installed usb-creator, I tried atvflash… frustrated I moved to the other option… I will factory reset. Bought a 2GB Sandisk Cruzer (will remove U3) and try that tonight.

I factory reset and tried the new Sandisk 2gb USB flash and it still didn’t boot the patch stick root.

Any ideas?

It’s probably a flash drive compatibility issue. San Disk drives in general tend to have issues.

Take a look here:

I’ve tried 5 different USB flash drives… all with the same results. Is there a current one on the list that is guaranteed to work (most of the ones you recommend are no longer available, since they are so old).

Finally had success tonight.

I think my problem all along was that I missed the minor point about not copying the ATV to the Applications Folder and just run it from the mounted DMG.

I got it working with an Officemax Toshiba 2GB flash ($6.99).