ATV4K Stutter after update

I’ve been running Infuse with an ATV4K and Synology NAS for around 12 months without a single issue. However I’ve been noticing recently that there’s some kind of stutter taking place at random times. It’s as if a few frames are skipped and happens with all of my mkv files. Any ideas or anyone else experiencing similar? Like I said, it’s a recent thing as I’ve had no problems previously. The only recent thing I’ve done is update the ATV4K to the latest build.

Welcome to the forum!

Can you provide the version number of Infuse and tvOS your currently running?
Are you running the tvOS beta?

Thank you!

tvOS 14.2 (18K57)

Infuse Pro 6.5.4 (3348)

I’m having the same issues (feels like framedrops), they happen on all different framerates too… but only in infuse, not in any streaming providers (hbo, netflix and so forth).

Played videos play fine, smooth as it should but every now and then there is a noticable ‘framedrop’ as best described atm. It’s not just a couple of times and irregular, it’s more like it’s every 20 or 30secs throughout the whole video.

I’m on (ATV4k) TvOs : 14.3 (18K5545e) & Infuse : v6.5.4 (3348)
*the ‘drops’ were present in previous versions of both TvOs & Infuse also.

Yeah, I’ve been having issues like this for probably about a year now. The devs have been responsive and have improved things but it’s still not 100% fixed I’m afraid. At this point I’m beginning to give up hope that it’ll ever be completely fixed.

The problems I’m seeing is only present when watching with subtitles. Are you watching with subtitles? Try switching them off to see if the problem goes away.

Tried with and without subtitles… and it seems to only occur (felt the ‘framedrops’ were gone anyways :slight_smile: ) when subtitles are enabled, these are are just basic .srt subtitles embedded in the mkv files. nothing fancy at all.

from what i can recall, i haven’t had these kinda issues before or else i’ve should have reacted earlier… if it has something to do with the ‘sub overlay fixing’ before that is glitching perhaps?
(Subtitles looks wierd on tvOS 14 Beta 2)

I’ve had the issue for quite a while. Over a year I would say. But I’m not sure. @james probably knows.

Anyway, according to my findings the issue only occurs with external subtitles like .srt and subtitles downloaded using the built in OpenSubtitles function. Original, embedded subtitles from BluRay rips are NOT affected.

I see framedrops sometimes too!
It’s happen randomly on most files (mp4, h264, 1080p)

Tried with embedded subs (srt) and external srt & without subs… embedded & external have ‘framedrops’ but i can’t seem to get when disabling subs… or i’m just staring myself blind and imagening things atm…

When watching a video file (no matter of format), i can see the ‘drops’ from time to time… but when i try to “look” for them when testing out different options its now the same thing than just watching… going abit nuts in the end :smiley:

i’ve got my ATV4k video settings @ 4kSDR/60, YCbCr, 4:4:4, Match Content On/On at Default. The ATV4K is connected straight to my TV (with an HDMI 2.1 cable) also so no receivers or soundbars in the chain.

What i can recall, i have not seen these kinda ‘framedrops’ before (1-2 months back).

1 Like