ATV4k 1st gen error connecting to mac

i been using infuse 7 on my 1st gen ATV 4K, i stopped using it for a month or so
now i get an error message every time i tried to play anything
deleted the share from app settings, the mac shows up when searching for a new share
re-added it but still got the same error message (reinstall didn’t work too)
checked mac share settings and everything seems to be OK
i have the ios app of infuse 7,2 and deleted the share and re-added it without any issues
i even added the mac address of my mac but still get the same error message

latest software release on ATV4k and infuse app

There are a few things to check.

  1. SMB is enabled on your Mac (more info here Set up file sharing on Mac - Apple Support)
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above)
  3. The folders/drives you wish to share are added to the list of Shared Folders
  4. Selected username and password are being entered in Infuse

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: Set up users, guests, and groups on Mac - Apple Support

Also, if you’ve recently installed an update for macOS, you may need to disable and then re-enable File Sharing to get it working again.


hi james
as you see in the images sharing on mac is ok

i did disabled the sharing after the update and re enabled it but still the same error message on ATV

Would you mind sending in a quick report from your device and posting the code here?

yfb31

Thanks.

It looks like Infuse is having issues finding the MBP on the network.

Are you using Wi-Fi or Ethernet on the ATV/Mac?

Are you using a dual band router by chance? One thing we’ve seen a few times is devices aren’t able to ‘see’ eachother if they are connected to different Wi-Fi bands. For example, if your MBP is on 2.4GHz and the ATV is on 5GHz, then they may not be able to connect. To check this, you might try creating separate networks for each band, and then ensure both devices are connected to the same one.

ATV using ethernet cable
MacBook using 5 ghz band

A month or so it was working properly but after unpluging it when i went on vacation for 2 weeks

The macbook appear on the list of shares on infuse app
How come it says it didn’t find the device?

After switching to 5ghz wifi
Everything seems to be ok

1 Like

re-pluged Ethernet cable and everything seems to be ok like before i don’t know if there’s something that need to be adjusted or fixed but i’m having no issue with my mac being on 5ghz and apple tv on wired connection

1 Like