ATV2's going into DFU and completing the JB for 5.0.2

Issue #1) I have two ATV2's. One regularly has jailbroken with every release and goes into DFU mode no problem by pressing the menu+play buttons as advertised. The other one I got about 5 months after the first and it has caused me a pile of grief. I discovered that it DOES NOT go into DFU mode in any conventional way (including the menu+down, screwing with clearing settings, uninstalling itunes etc etc etc). THE ONLY WAY the 2nd aTV2 goes into DFU mode is by plugging in the power, then the micro-USB and it enters DFU mode the regular way within 7 seconds, no problem at all.

Issue #2. For some reason I decided to put on 5.0.2 and JB them both, even though they were both operating fine running 4 and 4.4.4 no problem. Updating the first ATV2 - I ran through the JB, it came up with a 'can't restore' error or something like that. I ran sesonpass a 2nd time and no problem JB successful. Again, updating the 2nd ATV2 - massive PITA. I knew I'd have to plug in my power cable prior to putting in the micro-usb as with previous versions, but every other conceivable thing seemed to go wrong. I got errors 1604, 1602, 21 (and a few more I've forgotten about) time and time again. I'd enter DFU mode, the automatic restore would fire up, then it would hang for 5 minutes, then pop up with the error message for that attempt. I tried looking at hosts files, switching USB cables, reinstalling itunes, rebooting the computer repeatedly, purging all season's pass files. Nothing seemed to work for me. 
In the end here's what seemed to work for me: I did a complete system restore of the ATV2 in iTUNES. I rebooted the computer, completely started season's pass from scratch, ran through the JB process, got the error message 1604 (said a pile of bad words that unfortunately I think my daughters heard). I was going to give up. I put the ATV2 back onto my TV and fired it up for giggles. Lo and behold, it was working. Even though I had an error 1604.

Now - bear in mind I'd plugged the ATV2 into the TV on and off during the entire day it took me to f'ck around with this and nearly every time it showed that "plug the ATV2 into iTunes via. USB" icon. That said - I BET that any time I had the 1604 error earlier in the day the damn thing was actually working.

TL;DR - If you're having problems, do a system restore on the ATV2, JB from seasonspass from scratch, if you come up with a 1604, roll with it and plug the ATV2 into a TV 'cause hopefully it's actually working.