ATV2 XBMC Eden Beta Release with Icefilms - Not able to play video

Hi everyone.

I have JB my Atv2 4.4.4 with the jailbreak from firecore.  Installed xbmc via NitoTV.  XBMC just released their Eden Beta.  I then installed Icefilms.

After playing the first video (which loads and plays fine), if I choose to watch another video, it will count down as usual and then does not play the video.  Trying to play movies after has the same results.  Only way I can get it to work is by rebooting the atv2.  Even then, it sometimes does not work.

I have 2 atv2’s.  One is still 4.2 with XBMC Dharma 10.0.8 release.  Icefilms work perfectly with the older versions.

Any ideas?

I’ve got the same problem: I just JailBroke my ATV 2 yesterday with an Untethered Seas0npass installed Nito then added XBMC (Eden) downloaded from XBMC…then installed IceFilms … Wouldn’t play more than 5 seconds of any Series or Movie then it would “hang” … “Working” spinning til it either went pack to the Directory or just stopped “spinning”… I tried multiple sources … all the same results…

I tried PBS and other sites just to make sure that my connections were OK & they all worked… HD quality, Netflix etc… Just IceFilms… the reason by the way that I’ve gone to the trouble to JailBreak in the first place… :( Is there somebody working on this ?? I’ve tried to get on the IceFilms site today & it’s down !!!