ATV2 won't be recognised by either iTunes or seas0npass



So I’ve kinda been neglecting my ATV2 and now I wanna update my device to latest version. I can see that my ATV2 currently is running iOS 5.0.3. So I downloaded latest version of seas0napass and Firecore. But when I connect my ATV to my Macbook and open seas0npass to create a new ISPW file, it says I need to connect my ATV. But it already is.


So I thought I maybe could upgrade the ATV’s firmware to latest jailbreakable version (5.3). But when I choose “Update firmware” in the ATV settings it says “Already up-to-date”. Weird. Then I tried to “Force factory settings” but then it says that, that is not possible. No reason why it’s not possible.


Then I downloaded the iOS 5.3 firmware file from - - and wanted to restore using iTunes. But when I connect the ATV to my Macbook and open iTunes - iTunes can’t find the device. I’ve read and tried every guide on Apple’s support and knowledge forum and nothing seems to work.


I really, really hope that some one can help me. Either to factory reset, restore or anything that’ll make my device available for updating.


Can’t really take it to the Apple Retail store since it’s jailbroken :stuck_out_tongue:


Thanks in advance,

  • Morten


Please, someone help me out :frowning:

Try putting it in DFU mode, that might get it into a state that can be seen by itunes.

Plug ATV into computer via USB cable

Press MENU+PLAY on silver remote

After about 7 seconds the light on ATV should start blinking rapidly

After those 7 second release buttons and then start up iTunes and it should be seen.


If at all possible save the signatures before updating, I’m not aware of any ios 5.0.3 (according to this guide but it’s a good idea anyway.

When you attempt to upgrade to 5.3 you should run seasonpass, right click “create ipsw” and choose 5.3, otherwise you’re going to get 6.0 (latest) which isn’t jailbroken.