Atv2 v4.3(8F455) - All indications point to jailbreak success, SSH Connection refused. Ping Succeeded. - Detailed info provided.

 

I was able to trade my ATV3 that has been sitting unused for 5 months for a brand new unopened ATV2.  Yes I am sure it is an ATV2 based on the model number and that my TV reports it as 720 not 1080.  I have read tons of forums explaining how to jailbreak it.  None worked.

 

I am running 4.3 (8F455) and am attempting to keep it at this version as this will mostly be for XBMC and they recommend not going higher than this version.

 

Here is exactly what I did to get where I am now.  I supposedly have a jailbroken ATV2 that isn't jilbroken.

 

  1. Borrow Windows 7 PC from work.
  2. Download Seas0nPass v.0.3.52.4509
  3. Download iFaith, TotalCommander and new iTunes
  4. Open iFaith and dump shah blobs (there is 1)
  5. Plug in ATV2 and put in dfu mode
  6. Saved shsh blob (00000XXXXXXXXXXX_Apple_TV_2-4.3_(8F455)-blobs.ifaith) to ~/jailbreak/blob
  7. Used iFaith again to Build signed IPSW / Blobs
  8. Selected "Download it for me"
  9. Saved signed file (00000XXXXXXXXXXX_iFaith_Apple_TV_2-4.3 (8F455)_signed.ipsw) to ~/jailbreak/signed/
  10. Open Seas0nPass (0.3.52.4509) and click create IPSW
  11. Copy ~/My Docs/Seas0nPass to ~/jailbreal/Seas0nPass
  12. Drag (AppleTV2,1_4.3_8F455_SP_Restore.ipsw) to TotalCommander
  13. Drag (038-1318-062.dmg and 038-1328-062.dmg) files out of .ipsw above and extract to ~/jailbreak/innards
  14. Drag file from step 6 (00000XXXXXXXXXXX_iFaith_Apple_TV_2-4.3 (8F455)_signed.ipsw) to TotalCommander.
  15. Overwrite the two DMGs (038-1318-062.dmg and 038-1328-062.dmg) inside of (00000XXXXXXXXXXX_iFaith_Apple_TV_2-4.3 (8F455)_signed.ipsw using the files I extracted to ~/jailbreak/innards
  16. At this point I have tried 3 different methods:a) iFaith dfu powner (ireb)b) iRebc) Sn0wbreeze.I tried three different ways because even after it had "successfully jailbroken", I couldn't do anything with it so I started the whole process over at step 1 using another tool suggested in a forum.  Each time it resulted in the same thing, ATV2 ready to restore.  Keep in mind, I didn't use all three tools one after another.  I used them one at a time.  I tried Sn0wbreeze first and after I failed to get ssh I started the whole process again at step 1 and with iFaith dfu powner.  Once I restored via iTunes and it still didn't allow SSH I started again at step 1 and used iReb. Then Sn0wBreeze.  I just wanted to clarify this step so people who read this later and try it don't get confused. For the record, they all seemed to accomplish the same thing.
  17. Each method from previous step was done separately and resulted in ATV2 being put into DFU Recovery Mode.
  18. Open Itunes, shift + restore
  19. Select (00000XXXXXXXXXXX_iFaith_Apple_TV_2-4.3 (8F455)_signed.ipsw)
  20. Wait 15 minutes then get message that the ATV2 has been successfully restore and I should plug it into my TV.
  21. Disconnect USB from ATV2 & PC
  22. Move ATV2 to another room and attach to TV
  23. Go into settings and get ip
  24. Ping to verify IP
  25. Try to ssh into same ip.  This failed
  26. Just for Shits n Giggles, I tried tl telnet to ip.  This failed
  27. Pull power on ATV2 and plug back in
  28. Check ip
  29. Attempt ssh as root again after power cycle.  This failed

 

I have tried to be as detailed as possible to provide whatever helpful soul the full account of my efforts.  All attempts to ssh into the "jailbroken" ATV2 result in a connection refused on port 22.  The reason I had so many steps is these were the processes I was getting from various forums.  Not once was I ever able to just use Seas0nPass.  No matter what hosts trick, right click, use a signed.ipsw method I found online.

 

So here we are.  I have an ATV2.  It is supposedly jailbroken since the convoluted path I took resulted in iTunes saying that it was restored and ready to use.

 

So where do I go from here.  According to the messages of success I am getting, one would assume that I am jailbroken, however I am unable to use ssh so unable to install xbmc, block apple updates in hosts or do anything.  Can't see a reason to buy ATV_Flash.  From what I have read, it operates over SSH which I can't connect to.  So at this point I am stuck.

 

The only thing I can see as a trouble point was that I used Seas0nPass 4.4.4 (0.3.52.4509) to create the AppleTV2,1_4.3_8F455_SP_Restore.ipsw which i used to extract the 038-1318-062.dmg and 038-1328-062.dmg.  I could not find a Seas0nPass for 4.3 anywhere.  They don't seem to keep previous versions available and all my spidering of rapidshare and other dump sites came up negative.

 

All instructions I followed were for an untethered jb on 4.3 (8F455).

 

Thanks

Nevermind, I figured it out.

Hi, you explained your so well, that its kind of tutorial. Can you please explain you fix for problem also?