ATV2 stuck in DFU after successful jailbreak

I’m at my wit’s end. I’ve tried to jailbreak two ATV2s and have tried using multiple machines (PC and Mac) along with different micro usb cables and I’ve got stuck at the very end of the process.

After using seas0npass, it says the jailbreak has been successful, however when plugging the ATV2s in two the TV both appear to be in DFU mode with the flashing status light and the iTunes logo appearing.

I’ve downloaded TinyUmbrella but it appears that the ‘Exit recovery’ button has disappeared in the latest version, I’ve also tried RecBoot to kick it out of DFU but no joy. I’ve even tried with the power cable in and out and also recovery stock 5.2 in iTunes before running seas0npass.

Am I doing something glaringly wrong? Should iTunes be coming into it?

Any help would be appreciated!

I hope you get an answer I am a lifetime member. I will follow your post hope we get help I also got the the success then same thing very frustrating it was already jailbroken so I tried to re-jailbreak for the fixes and now stuck with factory 5.3 wish I hadn’t done that.

I have the same problem.

I fixed it Apple was still signing firmware 5.3 so with my Mac I did restore holding option key then locating the restore 5.3 firmware
After that was complete I got the new seasonpass from this link an started the jailbreak what I found what I was doing wrong. When I started the seasonpass I ran it without the micro being detected after it said insert USB I took it out but when I did that the software started running. This is wrong make sure that the whole jailbreak is done with the USB in if it runs without it will not work even though it said it was successful. Point being make sure the micro USB is in until the end and is decected during the initial SP launch. I counted I had done this jailbreak fifteen times no success. But leaving the USB in worked fine just a little thing like that keep the USB in make sure it detects it if it starts to create with the cord out will not work. Hope this helps someone those 15 tries was a nightmare. But now all good on eBay for sale lol.

Apple tv2 with 6.2.1 downgraded to 5.3 jailbreak solved!!! Stuck in DFU mode FINALLY solved!!

I accidentally upgraded my already jailbroken apple tv2 to 6.2.1 and for the longest time I couldn’t get it jailbroken again because of two reasons:

  1. I didn’t save my signatures (i didn’t know i had to)
  2. whenever I tried to re-jailbreak it, I was constantly get stuck in DFU mode.

I tried my Mac Pro (bought it approx 2012…its a Mac pro running 10.8.5) and i looked everywhere online for any info. I read that people were having success using their old PCs. So i did that (using an old IBM thinkpad) upgraded iTunes and got started, but of course I had no luck. Downloaded the latest season pass and still had no luck. As with everyone else with the same problem, I got frustrated with constantly being stuck in DFU mode…then for whatever reason my PC should me an error message that I never seen before OR I never read online before when it came to DFU error messages.

OLD PCs have a slower USB port speed than the newer mac computers and the Apple TVs. You cannot connect (communicate) a high speed usb port (apple tv2) with a slow PC (slow speed usb port). So I decided to switch back and try my mac pro instead. Here’s the steps that I used

  1. I first connected my apple tv2 to my Mac Pro at the beginning of the process,
  2. Installed the latest version of season pass
  3. RIGHT CLICK ON the ‘Create IPSW’ button to start the jailbreak process.
  4. This will give you different signature versions to choose from. I scrolled to the bottom and chose 5.3 (remember I still have version 6.2.1 on my apple tv2)
    Apple is STILL signing signatures for version 5.3.

Then continue thru the process as you normally would. Since you’re apple TV2 is already connected to your mac pro, you won’t be prompt for that step.
Once the light on the front of the Apple TV begins to flash rapidly, point the remote at the Apple TV and hold both the MENU and PLAY/PAUSE buttons for 7 seven seconds.
and Apple should download the latest software used to create a custom jailbreak file.

It was a long and frustrating process…But I FINALLY have my apple tv2 jailbroken.

Good luck!!

Hey denny330i

I did everything you said and it sucessfully installed BUT when I hooked it up to the TV it keeps looping back to the apple logo.

Any ideas…how to solve this?

BTW I installed Seas0npass with my Mac - might have to try PC instead!!

BTW I installed Seas0npass with my Mac - might have to try PC instead!!

After the restore to old firmware right click create 5.3 firmware in SP when you get the prompt to put in DFU
Mode remove the. Micro mini cord then plug in the power cord first then the Micro Mini cord then hold the play menu for about 12 seconds let it complete the jailbreak keeping both power and M Mini connected the entire process. When it says done press ok,then remove micro mini then the Power cord. I taught my friend on skype his worked first time it took me two times and it also worked. I think some people have been taking out the power cord after they get their ATV Into DFU mode going, leave it in the Apple TV needs that juice. Good Luck

Learn how to use DFU properly if you don’t already:

do not skip step 6! By skipping it you are not finishing the JB!

I did all the above, but when I connect ATV2 to my TV, the bulb on the front of the device constantly flashes (slow flashing) and do not see anything on TV. Only after I doing restart the device through iTunes, the ATV2 returns to act like he was before the break. What should I do?