ATV2 Software version 5.2

I had to reset my ATV2 for factory settings. During the process the new 5.2 was installed. 


Any ideas on how 5.2 is jailbroken ? 



yes. you will need a nutcracker and a 5th of whiskey. follow these steps:


  1. place your nuts in the nutcracker and squeeze until testicles rupture. 

  2. enjoy your whiskey.


You’re actually quite lucky, just released their jailbreak and although the ATV2 is not mentioned it will jailbreak it. Nevertheless if you use Plex or XMBC they will not have been updated for the new iOS. Alternatively if you use Seas0npass I have read that they are still signing 5.0.2.

Good luck 

I believe its the same JB, but Evati0n doesnt seem to do anything to apple tv.


agreed, I can’t get evasi0n to work to jailbreak the ATV2 running 5.2

Anyone got any suggestions??


Seas0npass back to 5.0.2


Seas0npass back to 5.0.2

wish I could, but I just can’t get seas0npass to work either, the ATV2 won’t even show up in iTunes for a restore (no white light flashing on ATV2 when plugged in with micro USB), nothing to do with the cable as tested it another ATV2 running 5.0.2 and worked fine.

Any ideas?

Try plugging in the power cord as well as the USB cord. It’s worked for me in the past.

Try with seas0npass like I did:

sn0wbreeze v2.9.8

More info here.