ATV2 running 5.2 - Jailbreak help needed



I have tried to JB a friends ATV2 and coming up against a brick wall.

I have JB and updated my own ATV2 many times so I have a fairly good understand of how to do it, so when a mate asked me to look at his to replicate the system I have I thought it would be easy!!!.. how wrong I am

The ATV2 in question is running 5.2 and will not even show up in itunes for a restore. The little white light doesn’t even come on when plugged in to my macbook (via micro USB) however my own ATV2 does show a light and show up in itunes (when plugged in via the same micro USB cable). Surely Apple haven’t deactivated the ‘Restore’ function in the latest release have they??

My itunes is v11, however I have tried plugging the ATV2 in to a windows PC running an old version of iTunes v10.** 

Bizarrely, I am now even finding that when I download and try to open seas0pass, i am getting an error message saying “Sorry, Seas0npass is not support on this device” even when there is no ATV2 plugged in whatsoever

Does anyone have any ideas what is happening here? 

Any guidance or help would be greatfully appreciated

Thank you


More info here.