ATV2 running 5.0 won't install media player


I have just updated my ATV2 to the latest Apple Software using Seas0npass.  This went without a hitch and I then downloaded and installed Firecore.  Again this all went fine - I then did a tethered boot again without issue.

When I took a look at what was installed by default there only seemed to be Maintenance which I assume is correct.  So I tried to install Media Player and it just sat there on the Installing screen.  I left it, and left it - the screen saver came on.  I still left it (about 10 minutes in the end) and then used to the Menu button to back out.  

I’ve tried several times, rebooted the ATV2 etc. etc. but it just wont install the media player!

NiToTV installs fine but I really need Media Player !


Any ideas??






Problem solved…

Not sure why, but for me I needed to install a bunch of stuff from Erica’s utils - only then would the media player install.  Not too sure if this is something unique to me or whether its a failure in the Firecore install process…

Anyhow, now its installed and working okay…  Its GREAT !!  So much quicker at media browsing than the older version and a major update to the interface.  Great Job! 


Hi, The same happens to me. Only “Maintenance” has installed, and manage extras doesn’t work. I can’t install media player. Could you share your solution?




What worked for me was to install NitoTV (for some reason this installed ok even though media player wouldn’t )
The go into NitoTV > Install Software. I have the following installed:

Screen Saver Hack
Erica Utilities

Then after restarting lowtide (it should prompt you to do this) I then tried to
Install Media Player which it did with no issues.

Not sure if this will work for you (please let me know!) but it was good
for me.

Good luck!



The problem is that only “maintenance” button has installed after jailbreak and install aTV Flash (black) 1.4.1 and, if I try to go to manage extras the wheel keeps turning and no option to install anything else.

Maintenance is the only extra button from original apple tv firmware 5.0 

No FC settings, netflix, Nito, browser… 

I tried to install XBMC 11.0 eden and it fails at dpkg -i org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb

Any idea?




If you go into Maintenance > Manage Extras then down at the bottom
of that screen you should see nitoTV and it should say “Not Installed”.
If you highlight this you should be able to install nitoTV and then follow the instructions
In my earlier post.

Sorry if I’m not following where your install is up to so let me know if the above doesn’t help.




Finally, this morning appeared nito Tv and others at Manage Extras. Perhaps the servers were busy yesterday. I’ve installed all nitoTV software, and now appears nitoTv, browser and media at main menu… I’ appears as installed XBMC sofware, but it doesn’t appears at main menu.

I don’t know if may I risk to install XBMC through terminal or wait until they develop that sofware for appleTV 5.0

Thanks for all.

Bartolomé xbmc is really only testing for ATV2 5.0 now, ive used it but it wasnt as stable as media player. im having same issue installing media player now so if i find a fix ill post back