Atv2 problems

Hello guys ! :smiley:
I have had my AT2 jailbroken for loooooong time…some days ago i decided to install the latest FW on it and have it tethered JB but in the end it wasn’t that easy to tether boot it
in the place i had it so i installed 5.3 again and unether JB it with seas0npass (latest one).
After the JB was successfull i installed aTV Flash (black), from there i installed nitoTV.
Now in nito TV i try to update some packages like openSSH but i always get errors.
First i pressed on update all, which runs this command apt-get -y -u dist-upgrade.
After a while i came across this error: Unmet dependacies. Try apt-get -f install with no packages.
After this it failed to install anything so i decided to run the apt-get -f install command.
So i said i will restore it to factory settings…but it wouldn’t do it…anyways after this was completely useless so i restored it on iTunes and re JB it again and installed aTV Flash (black) again.
I tried again to update the packages but again i had this error.
Now everything fails to install even from maintenance app it fails to install anything again.

You might want to run `apt-get -f install' to correct these: The following packages have unmet dependencies: rtadvd: Depends: firmware (< 9.0) but it is not installable sqlite3-dylib: Depends: firmware (< 3.0) but it is not installable uikittools: Depends: firmware (< 8.3) but it is not installable or com.saurik.patcyh but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I downloaded and tried to install via cydia autoinstall method these packages: rtadvd, sqlite3-dylib, uikittools and patcyh.
But even like this i still get the above error.

I remember it used to work back then.
What i’m doing wrong ?
I suppose some repos won’t work anymore and it causes troubles with dependacies, can i fix this somehow ?
Thanks for your time if you read this. :slight_smile: