ATV2 is "forgetting" Wifi, has to be rebooted to play films, Airport Extreme with USB HDD

Hi there,

I am running my ATV2 with 4.3 and it has been jailbroken with seas0npass (unthetered).

I am streaming my films using an Airport Extreme (5th generation) with an attached USB drive.

It happened some times that I was able to browse my films - but was not able to watch them… After using the reboot function from the maintrance menu all worked as suggested…

Also it happened several times that the film just stopped while watching it with a network error… My ATV2 just “forgot” my wifi… I had to choose my SSID and had to enter my password again in system settings  and all worked well again… This happened 2 or 3 times after the RC1 release.

An other strange problem it that media player seems not to “release” films I watched! The other day I wanted to delete films I already watched and got a message that it still is in use and can´t be deleted… A second try worked well.

 

Before using my USB HDD attached at the Airport Extreme I was using my shares on my Mac Book Pro. There still is / was the problem that a connected user stayed connected - even if I shut down my ATV2…

 

I am really afraid that flash(black) might share my shares and some one else might be able to connect to my shares… Or is it just a bug?