atv2 has frozen: led flashing


Please help. 

ATV2 is jailbroken on 4.3 (8F455)
Watched a movie tonight via xbmc without issues, but then when I stopped the movie, the atv2 froze. Did a hard reset (down + menu). Now white led is flashing once a second and only the apple logo is desplyed on screen. ATV2 was very hot!!

have connected it to itunes to restore, but it will update to the latest version which I am not keen on yet as dont want a tethered JB.

I know I saved my blobs when I jb, but I seem to have misplaced them after a HD failure.


I can also still SSH into it, so cna provide crash logs if needed…


thanks in advance



me too.


But I did not have XBMC installed. It just went black while in use. This was the latest SW, both Apple and jailbreak/aTV Flash. Sorry I don’t remember the exact versions. I tried the same reset type, nothing, then I unplugged the ATV from power and got the connect to iTunes logo. Not happy — to fix this I had to move a mini and monitor to the living room and do it all over again.


If I disconnect the ATV 2 from power that’s it, I get a connect to iTunes logo, extremely annoying if something goes wrong.

Same problem here - my incident happened when I was listening to music streaming into the living room from my office. This is the second time this has happened today. I “solved” the first instance by restoring/rebooting/reinstalling - whatever you want to call it - from Seas0nPass to aTV Flash Black start-to-finish. I’ve declined to futz with it by dragging all of my computer/cables into the living room to hunch over my entertainment center and meddle with it. A solution - or in the very least suggestion - would be much appreciated. This seems to be happening to several people today. 

I think what I will do, is run the ATV2 with only the media install so that I can stream video from my hard drive which is connected to my Airport extreme via USB. I won’t install anything else to see if I can isolate the issue. Not that I can fix it but if it goes for a while without repeating the issue then I know what doesn’t cause it. This being said, the sole reason I bought this software was to stream video other than that store in itunes.

If anyone else has this issue, chime in.


Sorry that I didn’t post much info about my ATV when responding - too tired I guess.

I have similar issue but when I restart I do not get stuck on logo screen but on “top movies”. So far, all I can do is reinstall.

I have the same problem. Whenever I install the atv flash and i pull out the plug it comes up with the Itunes logo! Pretty annoying! I have to unplug the power to make the DNS settings right so I can watch Netflix (I am not in the States, but in Denmark). Is there a workaround for that issue? 

I would really like to get some help here.


Any time you disconnect the power you are going to have to reconnect the ATV2 to your PC/Mac via USB and use SeasonPass to complete the boot. That will remain the case until an untethered jailbreak becomes available. This means in practice you have to have the ATV2 located where it is going to be used when you do the tethered boot and avoid removing the power.

Can anyone tell me if this is still the case with the current jailbreak for ATV2? So I really need to re-tether the ATV whenever the power is interrupted?

Thank you.


It’s true on any tethered version, past present and future.