ATV2 Firmware Install Failed

HI all,
i’ve tried every solution I can find before posting, so here goes:
I’ve got an ATV2 that I had previously jailbroken, and had no issues. I had to restore it recently, which installed the latest firmware. No problem, downloaded the latest version of Seasonpass and started the jailbreak. ATV2 gets into DFU mode with no issues (though I did have to use the powercable), and is detected by Seasonpass with no problems. It fails every time at the “firmware install failed” box.
I’ve tested 3 different micro usb cables, and just to be sure, I downloaded and installed an 5.30 ipsw file and flashed it to 5.3 using my normal cable with no issues. I’ve downloaded the earlier 9.3 version of seasonpass and tried that, didn’t work either. My theory is, because I can’t find the file, is after the message that the jailbroken firmware has been created, the file hasn’t actually been saved to my Mac. I’ve looked in Library, and also Documents ->Tethering, and can’t find a firmware file created today. Thoughts?

ATV 2 is on 5.3
Mac OSX is on 10.11 (yosemite beta)
both usb ports tried
tested with and without power cable
tested 3 different micro usb cables
boots into 5.3 fine.

Maybe you can find a solution here
I don’t have a MAC or else I’d help more.

Unfortunately nothing there to help. I did manage to get season pass to download a new version of the 5.3 software by restoring to the latest update via iTunes, and deleting the Tethered folder completely, but it still fails when attempting to install the jailbroken firmware. I’m at a loss

Did you ever get this JB to work for you. I am having the same problem with the same history.

As a workaround, I purchased another ATV2 off eBay and it is behaving in exactly the same way! :frowning:

2011 Mac mini with High Sierra 10.13.6 (seas0npass x.x.8) and same result on my 2009 MacBook Pro with Mt. Lion (seas0npass x.x.6).


I rebooted my 2011 Mac mini into its Mt Lion partition (10.8.5) and used Seas0npass 0.9.8, but I then got a “failed to reset USB counters” error message.

Research indicated that the fix for this problem is to go to Seas0npass preferences and uncheck “Quit iTunes before restore” and now I have untethered JB’d both of my ATV 2nd generations on iOS 5.3

I had reverted back to iOS 5.3 using this procedure:

I have not yet tried to JB tethered on 6.2.1

BTW: it took me 3 or 4 tries to get into DFU mode, with the power cable inserted at that point, to get it into DFU mode.