ATV2 Firmware failed


I am new here.

recently purchase atv2 (black) I tried to un tethered with seasonpass 0.97 and everything goes well until i get an FIRMWARE FAILED or if i do it again i do not get the done screen and software closesat the end. tried with tethered and follow to the letter and still not jailbreak. I did this with my mac since the pc can’t find server or not available.

your instruction are not the same from seasonpass to your link instruction. either way tried hours on end to JB and can’t get this going. I tried everything and when i plug back in the ATV2. looks like nothing has happen or it is just not breakable.

I have updated my Mac to all recent software including itune and all what was required to make this happen. a bit frustrating. iTunes open up by itself but i do not touch it since i do get this screen of restore and i do ignore that. or should it do something…i don’t because it’s not in the instructions.

My atv2 has the following version.

6.2.1 (iOS 7.1.2 - 11D258)

What is next…is this doable or not?