ATV2 cannot boot after power off. JBed using 0.70

I have successfully jailbroken my ATV2 using Seas0npass 0.70 and installed XBMC. But when I switch the power off to the ATV2, I cannot get it too boot up again. The white light in front just keeps blinking. I had the same problem after jailbreaking using Seas0npass 0.69 and Greenp0ison RC6.1.  This is very frustrating as the jailbreaking process seems to work. I cannot even do a tethered boot as Seas0npass says it's not needed as it is a untethered jailbreak.

Any help is greatly appreciated !

thanks,

Chris

Jailbreaking is not easy.  Typical problems are:

1)  Did not leave the JAILBREAK alone and still connected to the USB long enough after the GP said "jailbreak done".  have to not disconnect for at least a minute after this message appears

2)  USB port or USB cable is having issues.  Or you did not remove the power cable, before you started the jailbreak.  AppleTV power cable seems to interfear with the jailbreak.  The USB port was ignored multiple times by my computer, and would not talk to the connected AppleTV.

3)  Did not start with the latest RESTORE from Apple.  You have to have a good update and restore from Apple first.  before you start the jailbreak.  I used the RESTORE built into the AppleTV, not the one associated with ITUNES.

 

 

Thanks for responding to my problem.  Regarding the following :

 

2. Power cable - I definitely disconnected the power cable completely prior to putting the ATV2 in DFU mode and left it disconnected for the entire process. I bought a cheap micro USB cable off E-Bay, so I'm not sure if that could be the problem.

3. I definitely restored to the latest firmware before starting the jailbreak.

But I don't quite understand the first point. Are you saying that I should disconnect as soon as possible after the completion of the jailbreak ? I left the USB cable connected for at least a minute after it said completed because Greenpois0n required that, so I thought to play it safe, I should do that with Seas0npass as well. If you can clarify what you mean here that would be great.

Thanks again.

Chris

Seems like you did everything correct.  Yes - leave the AppleTV V2 connected to your computer USB for at least a full minute, do not disconnect.  You had it correct.

4)  the only other weird problem is someone mentioned that they blew a fuse in the Apple TV power cord.  the apple TV would never light up the indicator LED ever.

Bottom Line - you may need to try a different computer to do the jailbreak with.  If that fails after trying, then go to apple and swap out the apple TV, for a replacement unit.

 

Thanks again. Yes, I actually tried the jailbreak on 2 Macs and 1 PC, all the same result. :(

took me four hours of various experimnents to get my brother in laws Apple TV 2 to finally jailbreak.  Combination of known good USB cable, and making sure I pulled the plug on the APPLE TV 2 unit while attached to the computer.