ATV2 5.3 - Where is Plex ?



Thanks for the JB 5.3 !!

ATV2 successfully updated, but I don’t see where install Plex ?



Same here. Tried installing it manually via Terminal, nothing.

I know there are a few options to get Plex on 5.3 but haven’t had much luck with any yet. Since it is no longer in the Firecore Maintenance, has anyone tried these and succeeded?

  1. plexbmc plug-in for XBMC? - preferred
  2. Nito installer via custom URL
  3. plex connect - have tried this in the past but has required
    Re-install on too many occasions

Works fine!

Thanks Atxtra !


im getting errors when I install the plexbmc.  Which script is good?

I've installed this zip file
PleXBMC V3.1.5 for XBMC 12.0/Frodo

I’m like the same problem

I look for the solution of the Firecore team

For me it is very important Plex client


Same here. Please can anybody explain why Plex is gone in 5.3?

In 5.0.1 It was there.

Plex should be on de main screen and not in the extreme slow and buggy XMBC. To many clicks also.

I would imagine there’s a library issue between 5.0 and 5.3 that needs to be addressed.

Really?  Buggy is a valid complaint.  “To [sic] many clicks” is a complaint of the lazy.

I see I am not alone in asking this question.  Where did PLEX go any when will it return. PLEX just works, I give up on xbmc after 30 minutes. 

this is too bad guys...I bought aTV Flash because I though I could easy get Plex installed as I did in the past but it seems there is no chance now...I could spare some money I believe

Same here. BUT I expect to get a satisfying answer from Firecore, as I purchased aTV black yesterday, specially for the Plex-client, which is advertised on the website. I’m willing to use scripts and terminals, BUT want a good walkthrough, I’m not THAT good doing that stuff.

I’m in the same boat! Have tried installing PlecxConnect which doesn’t work. We really need that Plex app!